Tuesday 31 January 2017

%Warning: EIGRP Autonomous-System number must be provided

Make sure autonomous system is configured in address family.

R1(config-router)#router eigrp 100
R1(config-router)#address-family ipv4 vrf cust1
R1(config-router-af)#net  45.45.45.4 0.0.0.0
R1(config-router-af)#exit
%Warning: EIGRP Autonomous-System number must be provided
R1(config-router)#address-family ipv4 vrf cust1

R1(config-router-af)#autonomous 100


Saturday 7 January 2017

VRFlite configuration example



















PC1:-


PC1> show ip

NAME        : PC1[1]
IP/MASK     : 10.1.1.10/24
GATEWAY     : 10.1.1.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10000
RHOST:PORT  : 192.168.56.1:10001
MTU:        : 1500

Verification:-

PC1> ping 10.1.1.1
84 bytes from 10.1.1.1 icmp_seq=1 ttl=255 time=46.746 ms
84 bytes from 10.1.1.1 icmp_seq=2 ttl=255 time=47.038 ms
84 bytes from 10.1.1.1 icmp_seq=3 ttl=255 time=37.015 ms
84 bytes from 10.1.1.1 icmp_seq=4 ttl=255 time=47.171 ms
84 bytes from 10.1.1.1 icmp_seq=5 ttl=255 time=47.015 ms

PC1> ping 12.12.12.1
84 bytes from 12.12.12.1 icmp_seq=1 ttl=255 time=55.690 ms
84 bytes from 12.12.12.1 icmp_seq=2 ttl=255 time=49.691 ms
84 bytes from 12.12.12.1 icmp_seq=3 ttl=255 time=48.370 ms
84 bytes from 12.12.12.1 icmp_seq=4 ttl=255 time=56.310 ms
84 bytes from 12.12.12.1 icmp_seq=5 ttl=255 time=47.085 ms

PC1> ping 12.12.12.2
84 bytes from 12.12.12.2 icmp_seq=1 ttl=254 time=87.149 ms
84 bytes from 12.12.12.2 icmp_seq=2 ttl=254 time=93.756 ms
84 bytes from 12.12.12.2 icmp_seq=3 ttl=254 time=93.756 ms
84 bytes from 12.12.12.2 icmp_seq=4 ttl=254 time=78.428 ms
84 bytes from 12.12.12.2 icmp_seq=5 ttl=254 time=93.904 ms

PC1> ping 100.1.1.1
84 bytes from 100.1.1.1 icmp_seq=1 ttl=254 time=93.761 ms
84 bytes from 100.1.1.1 icmp_seq=2 ttl=254 time=94.341 ms
84 bytes from 100.1.1.1 icmp_seq=3 ttl=254 time=78.159 ms
84 bytes from 100.1.1.1 icmp_seq=4 ttl=254 time=77.972 ms
84 bytes from 100.1.1.1 icmp_seq=5 ttl=254 time=93.908 ms

PC1> ping 100.1.1.10
100.1.1.10 icmp_seq=1 timeout
100.1.1.10 icmp_seq=2 timeout
84 bytes from 100.1.1.10 icmp_seq=3 ttl=62 time=62.595 ms
84 bytes from 100.1.1.10 icmp_seq=4 ttl=62 time=62.613 ms
84 bytes from 100.1.1.10 icmp_seq=5 ttl=62 time=62.560 ms

PC2:-

C2> show ip

NAME        : PC2[1]
IP/MASK     : 20.1.1.10/24
GATEWAY     : 20.1.1.1
DNS         :
MAC         : 00:50:79:66:68:01
LPORT       : 10002
RHOST:PORT  : 192.168.56.1:10003
MTU:        : 1500

Verification:-

PC2> ping 200.1.1.10
200.1.1.10 icmp_seq=1 timeout
200.1.1.10 icmp_seq=2 timeout
84 bytes from 200.1.1.10 icmp_seq=3 ttl=62 time=62.585 ms
84 bytes from 200.1.1.10 icmp_seq=4 ttl=62 time=62.783 ms
84 bytes from 200.1.1.10 icmp_seq=5 ttl=62 time=62.385 ms


R1:-

ip vrf cust1

ip vrf cust2

interface FastEthernet0/0
 ip vrf forwarding cust1
 ip address 10.1.1.1 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet0/1
 ip vrf forwarding cust2
 ip address 20.1.1.1 255.255.255.0
 speed auto
 duplex auto

interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip vrf forwarding cust1
 ip address 12.12.12.1 255.255.255.0

interface FastEthernet1/0.20
 encapsulation dot1Q 20
 ip vrf forwarding cust2
 ip address 112.112.112.1 255.255.255.0

ip route vrf cust1 0.0.0.0 0.0.0.0 12.12.12.2
ip route vrf cust2 0.0.0.0 0.0.0.0 112.112.112.2

Verification:-

R1#sh ip vrf
  Name                             Default RD          Interfaces
  cust1                            <not set>           Fa0/0
                                                       Fa1/0.10
  cust2                            <not set>           Fa0/1
                                                       Fa1/0.20
R1#show ip route vrf cust1

Routing Table: cust1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is 12.12.12.2 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 12.12.12.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, FastEthernet1/0.10
L        12.12.12.1/32 is directly connected, FastEthernet1/0.10

R1#ping vrf cust1 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms

R1#ping vrf cust1 10.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/48/64 ms

R1#ping vrf cust1 100.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.1.1.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 84/342/1104 ms

R1#show ip route vrf cust2

Routing Table: cust2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is 112.112.112.2 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 112.112.112.2
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.1.1.0/24 is directly connected, FastEthernet0/1
L        20.1.1.1/32 is directly connected, FastEthernet0/1
      112.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        112.112.112.0/24 is directly connected, FastEthernet1/0.20
L        112.112.112.1/32 is directly connected, FastEthernet1/0.20

R1#ping vrf cust2 20.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/52/156 ms

R1#ping vrf cust2 200.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.1.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 92/350/1112 ms
R1#


PC3:-

PC3> show ip

NAME        : PC3[1]
IP/MASK     : 100.1.1.10/24
GATEWAY     : 100.1.1.1
DNS         :
MAC         : 00:50:79:66:68:02
LPORT       : 10005
RHOST:PORT  : 192.168.56.1:10004
MTU:        : 1500

Verification:-

PC3> ping 10.1.1.10
10.1.1.10 icmp_seq=1 timeout
10.1.1.10 icmp_seq=2 timeout
84 bytes from 10.1.1.10 icmp_seq=3 ttl=62 time=62.635 ms
84 bytes from 10.1.1.10 icmp_seq=4 ttl=62 time=62.703 ms
84 bytes from 10.1.1.10 icmp_seq=5 ttl=62 time=79.737 ms

PC4:-

PC4> show ip

NAME        : PC4[1]
IP/MASK     : 200.1.1.10/24
GATEWAY     : 200.1.1.1
DNS         :
MAC         : 00:50:79:66:68:03
LPORT       : 10007
RHOST:PORT  : 192.168.56.1:10006
MTU:        : 1500

Verification:-

PC4> ping 20.1.1.10
20.1.1.10 icmp_seq=1 timeout
20.1.1.10 icmp_seq=2 timeout
84 bytes from 20.1.1.10 icmp_seq=3 ttl=62 time=62.470 ms
84 bytes from 20.1.1.10 icmp_seq=4 ttl=62 time=46.973 ms
84 bytes from 20.1.1.10 icmp_seq=5 ttl=62 time=62.796 ms

R2:-

ip vrf cust1

ip vrf cust2

interface FastEthernet0/0
 ip vrf forwarding cust1
 ip address 100.1.1.1 255.255.255.0
 speed auto
 duplex auto

interface FastEthernet0/1
 ip vrf forwarding cust2
 ip address 200.1.1.1 255.255.255.0
 speed auto
 duplex auto

interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip vrf forwarding cust1
 ip address 12.12.12.2 255.255.255.0

interface FastEthernet1/0.20
 encapsulation dot1Q 20
 ip vrf forwarding cust2
 ip address 112.112.112.2 255.255.255.0

ip route vrf cust1 0.0.0.0 0.0.0.0 12.12.12.1
ip route vrf cust2 0.0.0.0 0.0.0.0 112.112.112.1

Verification:-

R2#sh ip vrf
  Name                             Default RD          Interfaces
  cust1                            <not set>           Fa0/0
                                                       Fa1/0.10
  cust12                           <not set>
  cust2                            <not set>           Fa0/1
                                                       Fa1/0.20
R2#show ip route vrf cust1

Routing Table: cust1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is 12.12.12.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 12.12.12.1
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, FastEthernet1/0.10
L        12.12.12.2/32 is directly connected, FastEthernet1/0.10
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.1.1.0/24 is directly connected, FastEthernet0/0
L        100.1.1.1/32 is directly connected, FastEthernet0/0

R2#ping vrf cust1 10.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 84/355/1136 ms
R2#ping vrf cust1 100.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.1.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/56/180 ms

R2#sh ip route vrf cust2

Routing Table: cust2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is 112.112.112.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 112.112.112.1
      112.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        112.112.112.0/24 is directly connected, FastEthernet1/0.20
L        112.112.112.2/32 is directly connected, FastEthernet1/0.20
      200.1.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        200.1.1.0/24 is directly connected, FastEthernet0/1
L        200.1.1.1/32 is directly connected, FastEthernet0/1

R2#ping vrf cust2 20.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 92/352/1116 ms

R2#ping vrf cust2 200.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/52/100 ms