Friday 31 March 2017

EIGRP neighborship on secondary address

All Cisco documents says it is not possible to create EIGRP neighborship on secondary addresses. 

Let test in our LAB and check if it really a true statement.



R1:-

interface FastEthernet0/0
 ip address 112.112.112.1 255.255.255.0 secondary
 ip address 12.12.12.1 255.255.255.0
 no shut
end

router eigrp 1
 network 112.112.112.1 0.0.0.0


R2:-

interface FastEthernet0/0
 ip address 112.112.112.2 255.255.255.0 secondary
 ip address 12.12.12.2 255.255.255.0
no shut

router eigrp 1
 network 112.112.112.2 0.0.0.0

Verification:-

R1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   12.12.12.2              Fa0/0             12 00:28:42   80   480  0  7

We saw in our verification section that neighborship has come up. But how it can be possible?


Neighborship is up because of the below two conditions:-

1.        Network command enable Eigrp on the interface and it will not check whether it is of primary address or secondary. As soon as network command subnet under EIGRP process matches with any interface it start sending the hello packets using the primary address.

2.       Both the neighbors must have primary address in same subnet.

Let’s have a look at the hello packets by enabling debug on R1. 

It shows that hello packets are generated using primary address as the source IP of hello packets. It means hello packet will always use Primary address as source.


EIGRP Packet debugging is on
R1#
*Apr  1 11:46:50.327: EIGRP: Received HELLO on FastEthernet0/0 nbr 12.12.12.2
*Apr  1 11:46:50.327:   AS 1, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Apr  1 11:46:53.439: EIGRP: Sending HELLO on FastEthernet0/0
*Apr  1 11:46:53.439:   AS 1, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0
*Apr  1 11:46:54.803: EIGRP: Received HELLO on FastEthernet0/0 nbr 12.12.12.2
*Apr  1 11:46:54.807:   AS 1, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0


Saturday 18 March 2017

Inter-AS option C - MPLS





R1:-

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

interface FastEthernet0/0
 description *** Connected to PC1 ***
 ip address 10.1.1.1 255.255.255.0
 no shut

interface FastEthernet0/1
 description *** Connected to R2 ***
 ip address 12.12.12.1 255.255.255.0
no shut

router ospf 100
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0  -<< Loopback advertisement
 network 10.1.1.1 0.0.0.0 area 0 --<<LAN subnet advertisement
 network 12.12.12.1 0.0.0.0 area 0 --<To create ospf neighbor ship with R2

R2:-

ip vrf cust1
 rd 1:1
 route-target export 1:1  --<< RT used in AS1
 route-target export 200:1  --<< RT used in AS2
 route-target import 1:1
 route-target import 200:1

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface FastEthernet0/1
 description *** Connected to R1 ***
 ip vrf forwarding cust1
 ip address 12.12.12.2 255.255.255.0
no shut

interface FastEthernet1/0
description *** Connected to R3 ***
 ip address 23.23.23.2 255.255.255.0
no shut

router ospf 100 vrf cust1
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 12.12.12.2 0.0.0.0 area 0

router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0

 address-family ipv4
  no neighbor 3.3.3.3 activate
  no auto-summary
  no synchronization
 exit-address-family

 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
redistribute ospf 100 vrf cust1 match internal external 1 external 2 --< To redistribute both internal and external routes otherwise only internal routes will be redistributed.
  no synchronization
 exit-address-family

mpls ldp router-id Loopback0 force

R3:-

interface Loopback0
 ip address 3.3.3.3 255.255.255.255

interface FastEthernet1/0
description *** Connected to R2 ***
 ip address 23.23.23.3 255.255.255.0
mpls ip
no shut

interface FastEthernet2/0
description *** Connected to R4 ***
 ip address 34.34.34.3 255.255.255.0
mpls ip
no shut

router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 neighbor internal peer-group
 neighbor internal remote-as 1
 neighbor internal update-source Loopback0
 neighbor 2.2.2.2 peer-group internal
 neighbor 4.4.4.4 peer-group internal
 neighbor 6.6.6.6 remote-as 2
 neighbor 6.6.6.6 ebgp-multihop 10  --<< eBGP between R3 and R6 both are RR of their respective AS.
 neighbor 6.6.6.6 update-source Loopback0

 address-family ipv4
  no neighbor 2.2.2.2 activate
  no neighbor 4.4.4.4 activate
  no neighbor 6.6.6.6 activate
  no auto-summary
  no synchronization
 exit-address-family

 address-family vpnv4
  neighbor internal send-community extended
  neighbor internal route-reflector-client  --<<<Configured R3 as RR
  neighbor 2.2.2.2 activate
  neighbor 4.4.4.4 activate
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-unchanged
 exit-address-family


mpls ldp router-id Loopback0 force

R4:-

interface Loopback0
 ip address 4.4.4.4 255.255.255.255

interface FastEthernet2/0
description *** Connected to R3 ***
 ip address 34.34.34.4 255.255.255.0
mpls ip
no shut

interface FastEthernet3/0
description *** Connected to R5 ***
 ip address 45.45.45.4 255.255.255.0
 mpls bgp forwarding
no shut

router ospf 1
 log-adjacency-changes
 redistribute bgp 1 subn route-map AS2_loopbacks--<< Advertise PE’s and RR’s loopback of AS2 to AS1
 network 4.4.4.4 0.0.0.0 area 0
 network 34.34.34.4 0.0.0.0 area 0
 network 45.45.45.4 0.0.0.0 area 0

router bgp 1
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 45.45.45.5 remote-as 2

 address-family ipv4
  no synchronization
  redistribute ospf 1 route-map AS1_loopbacks --<< Advertise PE and RR loopback to AS2
  no neighbor 3.3.3.3 activate
  neighbor 45.45.45.5 activate
  neighbor 45.45.45.5 send-label
  no auto-summary
 exit-address-family

 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
  neighbor 3.3.3.3 next-hop-self
 exit-address-family


ip access-list standard AS2_loopbacks
 permit 5.5.5.5
 permit 6.6.6.6
 permit 7.7.7.7

ip access-list standard AS1_loopbacks
 permit 2.2.2.2
 permit 4.4.4.4
 permit 3.3.3.3

route-map AS1_loopbacks permit 10
 match ip address AS1_loopbacks

route-map AS2_loopbacks permit 10
match ip address AS2_loopbacks

mpls ldp router-id Loopback0 force

R5:-

interface Loopback0
 ip address 5.5.5.5 255.255.255.255

interface FastEthernet1/0
description *** Connected to R6 ***
 ip address 56.56.56.5 255.255.255.0
mpls ip
no shut

interface FastEthernet3/0
description *** Connected to R4 ***
 ip address 45.45.45.5 255.255.255.0
mpls bgp forwarding
no shut

router ospf 2
 log-adjacency-changes
 redistribute bgp 2 subnets route-map AS1_loopback
 network 5.5.5.5 0.0.0.0 area 0
 network 56.56.56.5 0.0.0.0 area 0

router bgp 2
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 6.6.6.6 remote-as 2
 neighbor 6.6.6.6 update-source Loopback0
 neighbor 45.45.45.4 remote-as 1

 address-family ipv4
  no synchronization
  redistribute ospf 2 route-map AS2_loopback
  no neighbor 6.6.6.6 activate
  neighbor 45.45.45.4 activate
  neighbor 45.45.45.4 send-label
  no auto-summary
 exit-address-family

 address-family vpnv4
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-self
 exit-address-family


ip access-list standard As2_loopback
 permit 6.6.6.6
 permit 5.5.5.5
 permit 7.7.7.7


route-map loopback permit 10
 match ip address AS2_loopback

mpls ldp router-id Loopback0 force


ip access-list standard AS1_loopback
 permit 2.2.2.2
 permit 3.3.3.3
 permit 4.4.4.4


route-map loopback permit 10
 match ip address AS1_loopback

mpls ldp router-id Loopback0 force

router eigrp 2
 auto-summary

R6:-

interface Loopback0
 ip address 6.6.6.6 255.255.255.255


interface FastEthernet1/0
description *** Connected to R5 ***
 ip address 56.56.56.6 255.255.255.0
mpls ip
no shut

interface FastEthernet2/0
description *** Connected to R7 ***
 ip address 67.67.67.6 255.255.255.0
mpls ip
no shut

router ospf 2
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 56.56.56.6 0.0.0.0 area 0
 network 67.67.67.6 0.0.0.0 area 0

router bgp 2
 bgp log-neighbor-changes
 neighbor internal peer-group
 neighbor internal remote-as 2
 neighbor internal update-source Loopback0
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 ebgp-multihop 10
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 5.5.5.5 peer-group internal
 neighbor 7.7.7.7 peer-group internal

 address-family ipv4
  no synchronization
  no neighbor 3.3.3.3 activate
  no neighbor 5.5.5.5 activate
  no neighbor 7.7.7.7 activate
  no auto-summary
 exit-address-family

 address-family vpnv4
  neighbor internal send-community extended
  neighbor internal route-reflector-client
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
  neighbor 3.3.3.3 next-hop-unchanged
  neighbor 5.5.5.5 activate
  neighbor 7.7.7.7 activate
 exit-address-family

mpls ldp router-id Loopback0 force

R7:-

ip vrf cust1
 rd 2:2
 route-target export 200:1
 route-target export 1:1
 route-target import 200:1
 route-target import 1:1

interface Loopback0
 ip address 7.7.7.7 255.255.255.255

interface FastEthernet0/1
 description *** Connected to R8 ***
 ip vrf forwarding cust1
 ip address 78.78.78.7 255.255.255.0
no shut

interface FastEthernet2/0
description *** Connected to R6 ***
 ip address 67.67.67.7 255.255.255.0
mpls ip
no shut

router ospf 2
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 67.67.67.7 0.0.0.0 area 0

router bgp 2
 bgp log-neighbor-changes
 neighbor 6.6.6.6 remote-as 2
 neighbor 6.6.6.6 update-source Loopback0

 address-family ipv4
  no neighbor 6.6.6.6 activate
  no auto-summary
  no synchronization
 exit-address-family

 address-family vpnv4
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-self
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute eigrp 2 metric 2
  default-metric 1
  no synchronization
 exit-address-family

mpls ldp router-id Loopback0 force

router eigrp 1
 auto-summary
 !
 address-family ipv4 vrf cust1
  redistribute bgp 2 metric 1 1 1 1 1
  network 78.78.78.7 0.0.0.0
  auto-summary
  autonomous-system 2
 exit-address-family
  redistribute eigrp 2 metric 2

R8:-

interface Loopback0
 ip address 8.8.8.8 255.255.255.255

interface FastEthernet0/0
description *** Connected to R8 ***
 ip address 40.1.1.1 255.255.255.0
 no shut

interface FastEthernet0/1
description *** Connected to PC4 ******
 ip address 78.78.78.8 255.255.255.0
 no shut

router eigrp 2
 network 8.8.8.8 0.0.0.0
 network 40.1.1.1 0.0.0.0
 network 40.1.1.0 0.0.0.255
 network 78.78.78.8 0.0.0.0
 no auto-summary


Verification:-


PC1:-

PC1> ping 40.1.1.10
84 bytes from 40.1.1.10 icmp_seq=1 ttl=56 time=171.600 ms
84 bytes from 40.1.1.10 icmp_seq=2 ttl=56 time=218.400 ms
84 bytes from 40.1.1.10 icmp_seq=3 ttl=56 time=187.200 ms
84 bytes from 40.1.1.10 icmp_seq=4 ttl=56 time=234.000 ms
84 bytes from 40.1.1.10 icmp_seq=5 ttl=56 time=202.800 ms

R1:- 

R1#                    sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     8.0.0.0/32 is subnetted, 1 subnets
O E2    8.8.8.8 [110/1] via 12.12.12.2, 00:28:28, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
O E2    40.1.1.0 [110/1] via 12.12.12.2, 00:28:28, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
     78.0.0.0/24 is subnetted, 1 subnets
O E2    78.78.78.0 [110/1] via 12.12.12.2, 00:28:28, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/1

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
12.12.12.2        1   FULL/DR         00:00:35    12.12.12.2      FastEthernet0/1

R1#traceroute 40.1.1.10

Type escape sequence to abort.
Tracing the route to 40.1.1.10

  1 12.12.12.2 8 msec 12 msec 8 msec
  2 23.23.23.3 [MPLS: Labels 25/20 Exp 0] 136 msec 120 msec 104 msec
  3 34.34.34.4 [MPLS: Labels 24/20 Exp 0] 132 msec 120 msec 92 msec
  4 45.45.45.5 [MPLS: Labels 19/20 Exp 0] 88 msec 112 msec 128 msec
  5 56.56.56.6 [MPLS: Labels 17/20 Exp 0] 120 msec 148 msec 80 msec
  6 78.78.78.7 [MPLS: Label 20 Exp 0] 60 msec 124 msec 88 msec
  7 78.78.78.8 108 msec 64 msec 108 msec
  8 40.1.1.10 108 msec 152 msec 136 msec



R1:-

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

interface FastEthernet0/0
 description *** Connected to PC1 ***
 ip address 10.1.1.1 255.255.255.0
 no shut

interface FastEthernet0/1
 description *** Connected to R2 ***
 ip address 12.12.12.1 255.255.255.0
no shut

router ospf 100
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0  -<< Loopback advertisement
 network 10.1.1.1 0.0.0.0 area 0 --<<LAN subnet advertisement
 network 12.12.12.1 0.0.0.0 area 0 --<To create ospf neighbor ship with R2

R2:-

ip vrf cust1
 rd 1:1
 route-target export 1:1  --<< RT used in AS1
 route-target export 200:1  --<< RT used in AS2
 route-target import 1:1
 route-target import 200:1

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface FastEthernet0/1
 description *** Connected to R1 ***
 ip vrf forwarding cust1
 ip address 12.12.12.2 255.255.255.0
no shut

interface FastEthernet1/0
description *** Connected to R3 ***
 ip address 23.23.23.2 255.255.255.0
no shut

router ospf 100 vrf cust1
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 12.12.12.2 0.0.0.0 area 0

router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0

 address-family ipv4
  no neighbor 3.3.3.3 activate
  no auto-summary
  no synchronization
 exit-address-family

 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
redistribute ospf 100 vrf cust1 match internal external 1 external 2 --< To redistribute both internal and external routes otherwise only internal routes will be redistributed.
  no synchronization
 exit-address-family

mpls ldp router-id Loopback0 force

R3:-

interface Loopback0
 ip address 3.3.3.3 255.255.255.255

interface FastEthernet1/0
description *** Connected to R2 ***
 ip address 23.23.23.3 255.255.255.0
mpls ip
no shut

interface FastEthernet2/0
description *** Connected to R4 ***
 ip address 34.34.34.3 255.255.255.0
mpls ip
no shut

router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 neighbor internal peer-group
 neighbor internal remote-as 1
 neighbor internal update-source Loopback0
 neighbor 2.2.2.2 peer-group internal
 neighbor 4.4.4.4 peer-group internal
 neighbor 6.6.6.6 remote-as 2
 neighbor 6.6.6.6 ebgp-multihop 10  --<< eBGP between R3 and R6 both are RR of their respective AS.
 neighbor 6.6.6.6 update-source Loopback0

 address-family ipv4
  no neighbor 2.2.2.2 activate
  no neighbor 4.4.4.4 activate
  no neighbor 6.6.6.6 activate
  no auto-summary
  no synchronization
 exit-address-family

 address-family vpnv4
  neighbor internal send-community extended
  neighbor internal route-reflector-client  --<<<Configured R3 as RR
  neighbor 2.2.2.2 activate
  neighbor 4.4.4.4 activate
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-unchanged
 exit-address-family


mpls ldp router-id Loopback0 force

R4:-

interface Loopback0
 ip address 4.4.4.4 255.255.255.255

interface FastEthernet2/0
description *** Connected to R3 ***
 ip address 34.34.34.4 255.255.255.0
mpls ip
no shut

interface FastEthernet3/0
description *** Connected to R5 ***
 ip address 45.45.45.4 255.255.255.0
 mpls bgp forwarding
no shut

router ospf 1
 log-adjacency-changes
 redistribute bgp 1 subn route-map AS2_loopbacks--<< Advertise PE’s and RR’s loopback of AS2 to AS1
 network 4.4.4.4 0.0.0.0 area 0
 network 34.34.34.4 0.0.0.0 area 0
 network 45.45.45.4 0.0.0.0 area 0

router bgp 1
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 45.45.45.5 remote-as 2

 address-family ipv4
  no synchronization
  redistribute ospf 1 route-map AS1_loopbacks --<< Advertise PE and RR loopback to AS2
  no neighbor 3.3.3.3 activate
  neighbor 45.45.45.5 activate
  neighbor 45.45.45.5 send-label
  no auto-summary
 exit-address-family

 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
  neighbor 3.3.3.3 next-hop-self
 exit-address-family


ip access-list standard AS2_loopbacks
 permit 5.5.5.5
 permit 6.6.6.6
 permit 7.7.7.7

ip access-list standard AS1_loopbacks
 permit 2.2.2.2
 permit 4.4.4.4
 permit 3.3.3.3

route-map AS1_loopbacks permit 10
 match ip address AS1_loopbacks

route-map AS2_loopbacks permit 10
match ip address AS2_loopbacks

mpls ldp router-id Loopback0 force

R5:-

interface Loopback0
 ip address 5.5.5.5 255.255.255.255

interface FastEthernet1/0
description *** Connected to R6 ***
 ip address 56.56.56.5 255.255.255.0
mpls ip
no shut

interface FastEthernet3/0
description *** Connected to R4 ***
 ip address 45.45.45.5 255.255.255.0
mpls bgp forwarding
no shut

router ospf 2
 log-adjacency-changes
 redistribute bgp 2 subnets route-map AS1_loopback
 network 5.5.5.5 0.0.0.0 area 0
 network 56.56.56.5 0.0.0.0 area 0

router bgp 2
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 6.6.6.6 remote-as 2
 neighbor 6.6.6.6 update-source Loopback0
 neighbor 45.45.45.4 remote-as 1

 address-family ipv4
  no synchronization
  redistribute ospf 2 route-map AS2_loopback
  no neighbor 6.6.6.6 activate
  neighbor 45.45.45.4 activate
  neighbor 45.45.45.4 send-label
  no auto-summary
 exit-address-family

 address-family vpnv4
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-self
 exit-address-family


ip access-list standard As2_loopback
 permit 6.6.6.6
 permit 5.5.5.5
 permit 7.7.7.7


route-map loopback permit 10
 match ip address AS2_loopback

mpls ldp router-id Loopback0 force


ip access-list standard AS1_loopback
 permit 2.2.2.2
 permit 3.3.3.3
 permit 4.4.4.4


route-map loopback permit 10
 match ip address AS1_loopback

mpls ldp router-id Loopback0 force

router eigrp 2
 auto-summary

R6:-

interface Loopback0
 ip address 6.6.6.6 255.255.255.255


interface FastEthernet1/0
description *** Connected to R5 ***
 ip address 56.56.56.6 255.255.255.0
mpls ip
no shut

interface FastEthernet2/0
description *** Connected to R7 ***
 ip address 67.67.67.6 255.255.255.0
mpls ip
no shut

router ospf 2
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 56.56.56.6 0.0.0.0 area 0
 network 67.67.67.6 0.0.0.0 area 0

router bgp 2
 bgp log-neighbor-changes
 neighbor internal peer-group
 neighbor internal remote-as 2
 neighbor internal update-source Loopback0
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 ebgp-multihop 10
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 5.5.5.5 peer-group internal
 neighbor 7.7.7.7 peer-group internal

 address-family ipv4
  no synchronization
  no neighbor 3.3.3.3 activate
  no neighbor 5.5.5.5 activate
  no neighbor 7.7.7.7 activate
  no auto-summary
 exit-address-family

 address-family vpnv4
  neighbor internal send-community extended
  neighbor internal route-reflector-client
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
  neighbor 3.3.3.3 next-hop-unchanged
  neighbor 5.5.5.5 activate
  neighbor 7.7.7.7 activate
 exit-address-family

mpls ldp router-id Loopback0 force

R7:-

ip vrf cust1
 rd 2:2
 route-target export 200:1
 route-target export 1:1
 route-target import 200:1
 route-target import 1:1

interface Loopback0
 ip address 7.7.7.7 255.255.255.255

interface FastEthernet0/1
 description *** Connected to R8 ***
 ip vrf forwarding cust1
 ip address 78.78.78.7 255.255.255.0
no shut

interface FastEthernet2/0
description *** Connected to R6 ***
 ip address 67.67.67.7 255.255.255.0
mpls ip
no shut

router ospf 2
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 67.67.67.7 0.0.0.0 area 0

router bgp 2
 bgp log-neighbor-changes
 neighbor 6.6.6.6 remote-as 2
 neighbor 6.6.6.6 update-source Loopback0

 address-family ipv4
  no neighbor 6.6.6.6 activate
  no auto-summary
  no synchronization
 exit-address-family

 address-family vpnv4
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-self
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute eigrp 2 metric 2
  default-metric 1
  no synchronization
 exit-address-family

mpls ldp router-id Loopback0 force

router eigrp 1
 auto-summary
 !
 address-family ipv4 vrf cust1
  redistribute bgp 2 metric 1 1 1 1 1
  network 78.78.78.7 0.0.0.0
  auto-summary
  autonomous-system 2
 exit-address-family
  redistribute eigrp 2 metric 2

R8:-

interface Loopback0
 ip address 8.8.8.8 255.255.255.255

interface FastEthernet0/0
description *** Connected to R8 ***
 ip address 40.1.1.1 255.255.255.0
 no shut

interface FastEthernet0/1
description *** Connected to PC4 ******
 ip address 78.78.78.8 255.255.255.0
 no shut

router eigrp 2
 network 8.8.8.8 0.0.0.0
 network 40.1.1.1 0.0.0.0
 network 40.1.1.0 0.0.0.255
 network 78.78.78.8 0.0.0.0
 no auto-summary


Verification:-


PC1:-

PC1> ping 40.1.1.10
84 bytes from 40.1.1.10 icmp_seq=1 ttl=56 time=171.600 ms
84 bytes from 40.1.1.10 icmp_seq=2 ttl=56 time=218.400 ms
84 bytes from 40.1.1.10 icmp_seq=3 ttl=56 time=187.200 ms
84 bytes from 40.1.1.10 icmp_seq=4 ttl=56 time=234.000 ms
84 bytes from 40.1.1.10 icmp_seq=5 ttl=56 time=202.800 ms

R1:-

R1#  sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     8.0.0.0/32 is subnetted, 1 subnets
O E2    8.8.8.8 [110/1] via 12.12.12.2, 00:28:28, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
O E2    40.1.1.0 [110/1] via 12.12.12.2, 00:28:28, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
     78.0.0.0/24 is subnetted, 1 subnets
O E2    78.78.78.0 [110/1] via 12.12.12.2, 00:28:28, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/1

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
12.12.12.2        1   FULL/DR         00:00:35    12.12.12.2      FastEthernet0/1

R1#traceroute 40.1.1.10

Type escape sequence to abort.
Tracing the route to 40.1.1.10

  1 12.12.12.2 8 msec 12 msec 8 msec
  2 23.23.23.3 [MPLS: Labels 25/20 Exp 0] 136 msec 120 msec 104 msec
  3 34.34.34.4 [MPLS: Labels 24/20 Exp 0] 132 msec 120 msec 92 msec
  4 45.45.45.5 [MPLS: Labels 19/20 Exp 0] 88 msec 112 msec 128 msec
  5 56.56.56.6 [MPLS: Labels 17/20 Exp 0] 120 msec 148 msec 80 msec
  6 78.78.78.7 [MPLS: Label 20 Exp 0] 60 msec 124 msec 88 msec
  7 78.78.78.8 108 msec 64 msec 108 msec
  8 40.1.1.10 108 msec 152 msec 136 msec

R2:- 

R2#sh ip bgp summary  -<< No IPV4 BGP neighborship

R2#show ip bgp vpnv4 all summary
BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 124, main routing table version 124
9 network entries using 1233 bytes of memory
9 path entries using 612 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 240 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2977 total bytes of memory
BGP activity 40/31 prefixes, 62/53 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4     1     222     181      124    0    0 00:00:07        3

R2#show ip bgp vpnv4 all
BGP table version is 124, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf cust1)
*> 1.1.1.1/32       12.12.12.1              11         32768 ?
*>i8.8.8.8/32       7.7.7.7                  0    100      0 2 ?
*> 10.1.1.0/24      12.12.12.1              20         32768 ?
*> 12.12.12.0/24    0.0.0.0                  0         32768 ?
*>i40.1.1.0/24      7.7.7.7                  0    100      0 2 ?
*>i78.78.78.0/24    7.7.7.7                  0    100      0 2 ?
Route Distinguisher: 2:2
*>i8.8.8.8/32       7.7.7.7                  0    100      0 2 ?
*>i40.1.1.0/24      7.7.7.7                  0    100      0 2 ?
*>i78.78.78.0/24    7.7.7.7                  0    100      0 2 ?


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
O       34.34.34.0 [110/2] via 23.23.23.3, 00:45:38, FastEthernet1/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 23.23.23.3, 00:45:38, FastEthernet1/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/3] via 23.23.23.3, 00:45:38, FastEthernet1/0
     5.0.0.0/32 is subnetted, 1 subnets
O E2    5.5.5.5 [110/1] via 23.23.23.3, 00:36:35, FastEthernet1/0
     6.0.0.0/32 is subnetted, 1 subnets
O E2    6.6.6.6 [110/1] via 23.23.23.3, 00:36:36, FastEthernet1/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet1/0
     7.0.0.0/32 is subnetted, 1 subnets
O E2    7.7.7.7 [110/1] via 23.23.23.3, 00:36:37, FastEthernet1/0
     45.0.0.0/24 is subnetted, 1 subnets
O       45.45.45.0 [110/3] via 23.23.23.3, 00:45:40, FastEthernet1/0

R2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     34.34.34.0/24     0          Fa1/0      23.23.23.3
17     Pop tag     3.3.3.3/32        0          Fa1/0      23.23.23.3
18     16          4.4.4.4/32        0          Fa1/0      23.23.23.3
19     Untagged    1.1.1.1/32[V]     4548       Fa0/1      12.12.12.1
20     Untagged    10.1.1.0/24[V]    0          Fa0/1      12.12.12.1
21     Aggregate   12.12.12.0/24[V]  12008
22     18          45.45.45.0/24     0          Fa1/0      23.23.23.3
23     22          5.5.5.5/32        0          Fa1/0      23.23.23.3
24     24          6.6.6.6/32        0          Fa1/0      23.23.23.3
25     25          7.7.7.7/32        0          Fa1/0      23.23.23.3

R3:-

R3#show ip bgp vpnv4 all summary
BGP router identifier 3.3.3.3, local AS number 1
BGP table version is 67, main routing table version 67
6 network entries using 822 bytes of memory
6 path entries using 408 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 240 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2362 total bytes of memory
BGP activity 20/14 prefixes, 46/40 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4     1     182     223       67    0    0 00:01:48        3
4.4.4.4         4     1     220     234       67    0    0 00:06:54        0
6.6.6.6         4     2     111     116       67    0    0 00:06:52        3

R3#show ip bgp vpnv4 all
BGP table version is 67, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i1.1.1.1/32       2.2.2.2                 11    100      0 ?
*>i10.1.1.0/24      2.2.2.2                 20    100      0 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 ?
Route Distinguisher: 2:2
*> 8.8.8.8/32       7.7.7.7                                0 2 ?
*> 40.1.1.0/24      7.7.7.7                                0 2 ?
*> 78.78.78.0/24    7.7.7.7                                0 2 ?

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.34.34.0 is directly connected, FastEthernet2/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 23.23.23.2, 00:47:30, FastEthernet1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/2] via 34.34.34.4, 00:47:30, FastEthernet2/0
     5.0.0.0/32 is subnetted, 1 subnets
O E2    5.5.5.5 [110/1] via 34.34.34.4, 00:12:40, FastEthernet2/0
     6.0.0.0/32 is subnetted, 1 subnets
O E2    6.6.6.6 [110/1] via 34.34.34.4, 00:38:27, FastEthernet2/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet1/0
     7.0.0.0/32 is subnetted, 1 subnets
O E2    7.7.7.7 [110/1] via 34.34.34.4, 00:38:28, FastEthernet2/0
     45.0.0.0/24 is subnetted, 1 subnets
O       45.45.45.0 [110/2] via 34.34.34.4, 00:47:32, FastEthernet2/0

R3#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     4.4.4.4/32        2792       Fa2/0      34.34.34.4
17     Pop tag     2.2.2.2/32        18196      Fa1/0      23.23.23.2
18     Pop tag     45.45.45.0/24     3472       Fa2/0      34.34.34.4
22     25          5.5.5.5/32        0          Fa2/0      34.34.34.4
24     23          6.6.6.6/32        0          Fa2/0      34.34.34.4
25     24          7.7.7.7/32        7412       Fa2/0      34.34.34.4 

R4:-

R4# sh ip bgp summary
BGP router identifier 4.4.4.4, local AS number 1
BGP table version is 26, main routing table version 26
6 network entries using 768 bytes of memory
6 path entries using 312 bytes of memory
6/6 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 240 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2112 total bytes of memory
BGP activity 41/29 prefixes, 58/46 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
45.45.45.5      4            2      52      52       26    0    0 00:39:31        3

R4#show ip bgp vpnv4 all summary
BGP router identifier 4.4.4.4, local AS number 1
BGP table version is 82, main routing table version 82
6 network entries using 912 bytes of memory
6 path entries using 312 bytes of memory
6/6 BGP path/bestpath attribute entries using 792 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 240 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2304 total bytes of memory
BGP activity 41/29 prefixes, 58/46 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4            1      26      13       82    0    0 00:08:19        6

R4#show ip bgp vpnv4 all
BGP table version is 82, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i1.1.1.1/32       2.2.2.2                 11    100      0 ?
*>i10.1.1.0/24      2.2.2.2                 20    100      0 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 ?
Route Distinguisher: 2:2
*>i8.8.8.8/32       7.7.7.7                  0    100      0 2 ?
*>i40.1.1.0/24      7.7.7.7                  0    100      0 2 ?
*>i78.78.78.0/24    7.7.7.7                  0    100      0 2 ?

R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/3] via 34.34.34.3, 02:52:28, FastEthernet2/0
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 34.34.34.3, 02:52:38, FastEthernet2/0
      4.0.0.0/32 is subnetted, 1 subnets
C        4.4.4.4 is directly connected, Loopback0
      5.0.0.0/32 is subnetted, 1 subnets
B        5.5.5.5 [20/0] via 45.45.45.5, 00:39:45
      6.0.0.0/32 is subnetted, 1 subnets
B        6.6.6.6 [20/2] via 45.45.45.5, 00:39:45
      7.0.0.0/32 is subnetted, 1 subnets
B        7.7.7.7 [20/3] via 45.45.45.5, 00:39:45
      23.0.0.0/24 is subnetted, 1 subnets
O        23.23.23.0 [110/2] via 34.34.34.3, 02:52:38, FastEthernet2/0
      34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.34.34.0/24 is directly connected, FastEthernet2/0
L        34.34.34.4/32 is directly connected, FastEthernet2/0
      45.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        45.45.45.0/24 is directly connected, FastEthernet3/0
L        45.45.45.4/32 is directly connected, FastEthernet3/0
C        45.45.45.5/32 is directly connected, FastEthernet3/0

R4#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  45.45.45.5/32    0             Fa3/0      45.45.45.5
17         Pop Label  3.3.3.3/32       8674          Fa2/0      34.34.34.3
18         Pop Label  23.23.23.0/24    0             Fa2/0      34.34.34.3
19         17         2.2.2.2/32       11368         Fa2/0      34.34.34.3
23         17         6.6.6.6/32       8290          Fa3/0      45.45.45.5
24         19         7.7.7.7/32       8276          Fa3/0      45.45.45.5
25         Pop Label  5.5.5.5/32       0             Fa3/0      45.45.45.5

R5:-

R5#  sh ip bgp summary
BGP router identifier 5.5.5.5, local AS number 2
BGP table version is 20, main routing table version 20
6 network entries using 768 bytes of memory
6 path entries using 312 bytes of memory
6/6 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 810 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2682 total bytes of memory
BGP activity 29/17 prefixes, 57/45 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
45.45.45.4      4            1      53      53       20    0    0 00:40:19        3

R5#show ip bgp vpnv4 all summary
BGP router identifier 5.5.5.5, local AS number 2
BGP table version is 82, main routing table version 82
6 network entries using 912 bytes of memory
6 path entries using 312 bytes of memory
4/4 BGP path/bestpath attribute entries using 528 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 810 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2610 total bytes of memory
BGP activity 29/17 prefixes, 57/45 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
6.6.6.6         4            2      34      19       82    0    0 00:14:22        6

R5#show ip bgp vpnv4 all
BGP table version is 82, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i1.1.1.1/32       2.2.2.2                  0    100      0 1 ?
*>i10.1.1.0/24      2.2.2.2                  0    100      0 1 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 1 ?
Route Distinguisher: 2:2
*>i8.8.8.8/32       7.7.7.7                  2    100      0 ?
*>i40.1.1.0/24      7.7.7.7                  2    100      0 ?
*>i78.78.78.0/24    7.7.7.7                  0    100      0 ?

R5#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
B        2.2.2.2 [20/3] via 45.45.45.4, 00:40:35
      3.0.0.0/32 is subnetted, 1 subnets
B        3.3.3.3 [20/2] via 45.45.45.4, 00:40:35
      4.0.0.0/32 is subnetted, 1 subnets
B        4.4.4.4 [20/0] via 45.45.45.4, 00:40:35
      5.0.0.0/32 is subnetted, 1 subnets
C        5.5.5.5 is directly connected, Loopback0
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/2] via 56.56.56.6, 02:53:31, FastEthernet1/0
      7.0.0.0/32 is subnetted, 1 subnets
O        7.7.7.7 [110/3] via 56.56.56.6, 02:53:21, FastEthernet1/0
      45.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        45.45.45.0/24 is directly connected, FastEthernet3/0
C        45.45.45.4/32 is directly connected, FastEthernet3/0
L        45.45.45.5/32 is directly connected, FastEthernet3/0
      56.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        56.56.56.0/24 is directly connected, FastEthernet1/0
L        56.56.56.5/32 is directly connected, FastEthernet1/0
      67.0.0.0/24 is subnetted, 1 subnets
O        67.67.67.0 [110/2] via 56.56.56.6, 02:53:21, FastEthernet1/0

R5#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  45.45.45.4/32    0             Fa3/0      45.45.45.4
17         Pop Label  6.6.6.6/32       8164          Fa1/0      56.56.56.6
18         Pop Label  67.67.67.0/24    0             Fa1/0      56.56.56.6
19         17         7.7.7.7/32       9140          Fa1/0      56.56.56.6
20         20         2:2:40.1.1.0/24  0             Fa1/0      56.56.56.6
21         21         2:2:78.78.78.0/24   \
                                       0             Fa1/0      56.56.56.6
22         19         2:2:8.8.8.8/32   0             Fa1/0      56.56.56.6
23         17         3.3.3.3/32       9357          Fa3/0      45.45.45.4
24         19         2.2.2.2/32       11368         Fa3/0      45.45.45.4
25         Pop Label  4.4.4.4/32       0             Fa3/0      45.45.45.4
R5#

R6# sh ip bgp vpnv4 all summary
BGP router identifier 6.6.6.6, local AS number 2
BGP table version is 40, main routing table version 40
6 network entries using 912 bytes of memory
6 path entries using 312 bytes of memory
4/4 BGP path/bestpath attribute entries using 528 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 810 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2586 total bytes of memory
BGP activity 27/21 prefixes, 44/38 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4            1      21      22       40    0    0 00:10:42        3
5.5.5.5         4            2      21      36       40    0    0 00:16:00        0
7.7.7.7         4            2      14      16       40    0    0 00:07:56        3

R6#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O E2     2.2.2.2 [110/1] via 56.56.56.5, 00:42:02, FastEthernet1/0
      3.0.0.0/32 is subnetted, 1 subnets
O E2     3.3.3.3 [110/1] via 56.56.56.5, 00:42:02, FastEthernet1/0
      4.0.0.0/32 is subnetted, 1 subnets
O E2     4.4.4.4 [110/1] via 56.56.56.5, 00:24:27, FastEthernet1/0
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/2] via 56.56.56.5, 02:55:03, FastEthernet1/0
      6.0.0.0/32 is subnetted, 1 subnets
C        6.6.6.6 is directly connected, Loopback0
      7.0.0.0/32 is subnetted, 1 subnets
O        7.7.7.7 [110/2] via 67.67.67.7, 02:54:53, FastEthernet2/0
      56.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        56.56.56.0/24 is directly connected, FastEthernet1/0
L        56.56.56.6/32 is directly connected, FastEthernet1/0
      67.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        67.67.67.0/24 is directly connected, FastEthernet2/0
L        67.67.67.6/32 is directly connected, FastEthernet2/0

R6#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  5.5.5.5/32       16169         Fa1/0      56.56.56.5
17         Pop Label  7.7.7.7/32       25537         Fa2/0      67.67.67.7
18         24         2.2.2.2/32       11368         Fa1/0      56.56.56.5
19         23         3.3.3.3/32       0             Fa1/0      56.56.56.5
20         25         4.4.4.4/32       0             Fa1/0      56.56.56.5
31         19         2:2:8.8.8.8/32   0             Fa2/0      67.67.67.7
32         20         2:2:40.1.1.0/24  0             Fa2/0      67.67.67.7
33         21         2:2:78.78.78.0/24   \
                                       0             Fa2/0      67.67.67.7

R7:-

R7#sh ip bgp summary --<< No IPV4 BGP neighbor


R7#sh ip bgp vpnv4 all summary
BGP router identifier 7.7.7.7, local AS number 2
BGP table version is 130, main routing table version 130
9 network entries using 1233 bytes of memory
9 path entries using 612 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 810 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3299 total bytes of memory
BGP activity 40/31 prefixes, 67/58 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
6.6.6.6         4     2     150     128      130    0    0 00:09:41        3

R7#sh ip bgp vpnv4 all
BGP table version is 130, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i1.1.1.1/32       2.2.2.2                  0    100      0 1 ?
*>i10.1.1.0/24      2.2.2.2                  0    100      0 1 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 1 ?
Route Distinguisher: 2:2 (default for vrf cust1)
*>i1.1.1.1/32       2.2.2.2                  0    100      0 1 ?
*> 8.8.8.8/32       78.78.78.8               2         32768 ?
*>i10.1.1.0/24      2.2.2.2                  0    100      0 1 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 1 ?
*> 40.1.1.0/24      78.78.78.8               2         32768 ?
*> 78.78.78.0/24    0.0.0.0                  0         32768 ?

R7#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
O E2    2.2.2.2 [110/1] via 67.67.67.6, 00:44:19, FastEthernet2/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/1] via 67.67.67.6, 00:44:19, FastEthernet2/0
     4.0.0.0/32 is subnetted, 1 subnets
O E2    4.4.4.4 [110/1] via 67.67.67.6, 00:44:19, FastEthernet2/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/3] via 67.67.67.6, 01:05:55, FastEthernet2/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/2] via 67.67.67.6, 01:05:55, FastEthernet2/0
     67.0.0.0/24 is subnetted, 1 subnets
C       67.67.67.0 is directly connected, FastEthernet2/0
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback0
     56.0.0.0/24 is subnetted, 1 subnets
O       56.56.56.0 [110/2] via 67.67.67.6, 01:05:57, FastEthernet2/0

R7#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     56.56.56.0/24     0          Fa2/0      67.67.67.6
17     16          5.5.5.5/32        0          Fa2/0      67.67.67.6
18     Pop tag     6.6.6.6/32        0          Fa2/0      67.67.67.6
19     Untagged    8.8.8.8/32[V]     0          Fa0/1      78.78.78.8
20     Untagged    40.1.1.0/24[V]    13404      Fa0/1      78.78.78.8
21     Aggregate   78.78.78.0/24[V]  0
22     18          2.2.2.2/32        0          Fa2/0      67.67.67.6
23     19          3.3.3.3/32        0          Fa2/0      67.67.67.6
25     20          4.4.4.4/32        0          Fa2/0      67.67.67.6
R7#

R8:-

R8#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
D EX    1.1.1.1 [170/2560025856] via 78.78.78.7, 00:09:37, FastEthernet0/1
     8.0.0.0/32 is subnetted, 1 subnets
C       8.8.8.8 is directly connected, Loopback0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.1.1.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
D EX    10.1.1.0 [170/2560025856] via 78.78.78.7, 00:09:37, FastEthernet0/1
     78.0.0.0/24 is subnetted, 1 subnets
C       78.78.78.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
D EX    12.12.12.0 [170/2560025856] via 78.78.78.7, 00:09:38, FastEthernet0/1

R8#traceroute 10.1.1.10

Type escape sequence to abort.
Tracing the route to 10.1.1.10

  1 78.78.78.7 12 msec 12 msec 8 msec
  2 67.67.67.6 [MPLS: Labels 18/20 Exp 0] 124 msec 96 msec 132 msec
  3 56.56.56.5 [MPLS: Labels 24/20 Exp 0] 140 msec 108 msec 100 msec
  4 45.45.45.4 [MPLS: Labels 19/20 Exp 0] 112 msec 96 msec 88 msec
  5 34.34.34.3 [MPLS: Labels 17/20 Exp 0] 68 msec 140 msec 80 msec
  6 12.12.12.2 [MPLS: Label 20 Exp 0] 100 msec 100 msec 116 msec
  7 12.12.12.1 92 msec 100 msec 96 msec
  8 10.1.1.10 124 msec 116 msec 120 msec
R8#

PC4:-

PC4> ping 10.1.1.10
84 bytes from 10.1.1.10 icmp_seq=1 ttl=56 time=249.603 ms
84 bytes from 10.1.1.10 icmp_seq=2 ttl=56 time=187.203 ms
84 bytes from 10.1.1.10 icmp_seq=3 ttl=56 time=218.403 ms
84 bytes from 10.1.1.10 icmp_seq=4 ttl=56 time=187.202 ms
84 bytes from 10.1.1.10 icmp_seq=5 ttl=56 time=202.803 ms