Thursday 16 March 2017

Inter AS Option B - MPLS




PC1:-

PC1> show ip

NAME        : PC1[1]
IP/MASK     : 10.1.1.10/24
GATEWAY     : 10.1.1.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10000
RHOST:PORT  : 127.0.0.1:10001
MTU:        : 1500
  
R1:-

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

interface FastEthernet0/0
 description *** Connected to PC1***
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet0/1
 description *** Connected to R2 ***
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto

router ospf 100
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0

R2:-

ip vrf cust1
 rd 1:1
 route-target export 1:1
 route-target export 200:1
 route-target import 1:1
 route-target import 200:1

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface FastEthernet0/1
ip vrf forwarding cust1
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet1/0
 ip address 23.23.23.2 255.255.255.0
 speed 100
 full-duplex
 mpls ip

router ospf 100 vrf cust1
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 12.12.12.2 0.0.0.0 area 0

router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0

router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 1
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary

 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute ospf 100 vrf cust1 match internal external 1 external 2
  no synchronization
 exit-address-family

mpls ldp router-id Loopback0 force

R3:-

interface Loopback0
 ip address 3.3.3.3 255.255.255.255

interface FastEthernet1/0
 ip address 23.23.23.3 255.255.255.0
 speed 100
 full-duplex
 mpls ip

interface FastEthernet2/0
 ip address 34.34.34.3 255.255.255.0
 duplex auto
 speed auto
 mpls ip

router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0

mpls ldp router-id Loopback0 force

R4:-

interface Loopback0
ip address 4.4.4.4 255.255.255.255

interface FastEthernet0/0
ip vrf forwarding cust1
ip address 20.1.1.1 255.255.255.0
no shut

interface FastEthernet2/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
mpls ip
no shut

interface FastEthernet3/0
ip address 45.45.45.4 255.255.255.0
mpls bgp forwarding
no shut

router ospf 100 vrf cust1
log-adjacency-changes
network 20.1.1.1 0.0.0.0 area 0

router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 34.34.34.4 0.0.0.0 area 0

router bgp 1
no synchronization
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
neighbor 45.45.45.5 remote-as 2
neighbor 45.45.45.5 send-label
no auto-summary

address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 next-hop-self
neighbor 45.45.45.5 activate
neighbor 45.45.45.5 send-community extended
exit-address-family

mpls ldp router-id Loopback0 force

R4#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  3.3.3.3/32       0             Fa2/0      34.34.34.3
17         16         2.2.2.2/32       0             Fa2/0      34.34.34.3
18         Pop Label  23.23.23.0/24    0             Fa2/0      34.34.34.3
19         27         2:2:40.1.1.0/24  4232          Fa3/0      45.45.45.5
21         20         1:1:10.1.1.0/24  0             Fa2/0      34.34.34.3
22         19         1:1:1.1.1.1/32   0             Fa2/0      34.34.34.3
23         21         1:1:12.12.12.0/24   
                                       10280         Fa2/0      34.34.34.3
24         Pop Label  45.45.45.5/32    0             Fa3/0      45.45.45.5
25         26         2:2:78.78.78.0/24   
                                       0             Fa3/0      45.45.45.5

26         18         2:2:8.8.8.8/32   0             Fa3/0      45.45.45.5

R5:-

Ip routing

interface Loopback0
 ip address 5.5.5.5 255.255.255.255

interface FastEthernet0/0
ip vrf forwarding cust1
 ip address 30.1.1.1 255.255.255.0
 duplex auto
 speed auto
no shut

interface FastEthernet1/0
 ip address 56.56.56.5 255.255.255.0
 speed 100
 full-duplex
 mpls ip
no shut

interface FastEthernet3/0
ip address 45.45.45.5 255.255.255.0
mpls bgp forwarding
no shut

router eigrp 2
 auto-summary
  address-family ipv4 vrf cust1
  redistribute bgp 2 metric 1 1 1 1 1
  network 30.1.1.1 0.0.0.0
  auto-summary
  autonomous-system 2
 exit-address-family

router ospf 2
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 56.56.56.5 0.0.0.0 area 0

router bgp 2
 no synchronization
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 7.7.7.7 remote-as 2
 neighbor 7.7.7.7 update-source Loopback0
 neighbor 45.45.45.4 remote-as 1
 neighbor 45.45.45.4 send-label
 no auto-summary
 !
 address-family vpnv4
  neighbor 7.7.7.7 activate
  neighbor 7.7.7.7 send-community extended
  neighbor 7.7.7.7 next-hop-self
  neighbor 45.45.45.4 activate
  neighbor 45.45.45.4 send-community extended
 exit-address-family

mpls ldp router-id Loopback0 force

       
R6:-

interface Loopback0
 ip address 6.6.6.6 255.255.255.255

interface FastEthernet1/0
 ip address 56.56.56.6 255.255.255.0
 speed 100
 full-duplex
 mpls ip

interface FastEthernet2/0
 ip address 67.67.67.6 255.255.255.0
 duplex auto
 speed auto
 mpls ip

router ospf 2
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 56.56.56.6 0.0.0.0 area 0
 network 67.67.67.6 0.0.0.0 area 0


R7:-

ip vrf cust1
 rd 2:2
 route-target export 200:1
 route-target export 1:1
 route-target import 200:1
 route-target import 1:1

interface Loopback0
 ip address 7.7.7.7 255.255.255.255


interface FastEthernet0/1
  ip vrf forwarding cust1
 ip address 78.78.78.7 255.255.255.0
 duplex auto
 speed auto


router eigrp 1
 auto-summary
  address-family ipv4 vrf cust1
  redistribute bgp 2 metric 1 1 1 1 1
  network 78.78.78.7 0.0.0.0
  auto-summary
  autonomous-system 2
 exit-address-family

router ospf 2
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 67.67.67.7 0.0.0.0 area 0

router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 2
 neighbor 5.5.5.5 update-source Loopback0
 no auto-summary

 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute eigrp 2 metric 2
  default-metric 1
  no synchronization
 exit-address-family
  
R8:-

interface Loopback0
 ip address 8.8.8.8 255.255.255.255

interface FastEthernet0/0
 ip address 40.1.1.1 255.255.255.0
 duplex auto
 speed auto


interface FastEthernet0/1
ip address 78.78.78.8 255.255.255.0
 duplex auto
 speed auto

router eigrp 2
 network 8.8.8.8 0.0.0.0
 network 40.1.1.1 0.0.0.0
 network 40.1.1.0 0.0.0.255
 network 78.78.78.8 0.0.0.0
 no auto-summary

PC4:-

PC4> show ip

NAME        : PC4[1]
IP/MASK     : 40.1.1.10/24
GATEWAY     : 40.1.1.1
DNS         :
MAC         : 00:50:79:66:68:03
LPORT       : 10019
RHOST:PORT  : 127.0.0.1:10018
MTU:        : 1500

Verification:-

PC1:-

PC1> ping 40.1.1.10
84 bytes from 40.1.1.10 icmp_seq=1 ttl=56 time=171.600 ms
84 bytes from 40.1.1.10 icmp_seq=2 ttl=56 time=218.400 ms
84 bytes from 40.1.1.10 icmp_seq=3 ttl=56 time=187.200 ms
84 bytes from 40.1.1.10 icmp_seq=4 ttl=56 time=234.000 ms
84 bytes from 40.1.1.10 icmp_seq=5 ttl=56 time=202.800 ms

R1:-

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     8.0.0.0/32 is subnetted, 1 subnets
O E2    8.8.8.8 [110/1] via 12.12.12.2, 02:05:51, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
O E2    40.1.1.0 [110/1] via 12.12.12.2, 02:05:46, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
     78.0.0.0/24 is subnetted, 1 subnets
O E2    78.78.78.0 [110/1] via 12.12.12.2, 02:05:51, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/1

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
12.12.12.2        1   FULL/DR         00:00:36    12.12.12.2      FastEthernet0/1

R1#traceroute 40.1.1.1

Type escape sequence to abort.
Tracing the route to 40.1.1.1

  1 12.12.12.2 40 msec 32 msec 28 msec
  2 23.23.23.3 [MPLS: Labels 17/19 Exp 0] 188 msec 156 msec 172 msec
  3 34.34.34.4 [MPLS: Label 19 Exp 0] 140 msec 172 msec 204 msec
  4 45.45.45.5 [MPLS: Label 27 Exp 0] 172 msec 168 msec 176 msec
  5 56.56.56.6 [MPLS: Labels 16/17 Exp 0] 188 msec 168 msec 172 msec
  6 78.78.78.7 [MPLS: Label 17 Exp 0] 128 msec 136 msec 136 msec
  7 78.78.78.8 188 msec 160 msec 156 msec

R2:-

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:35    23.23.23.3      FastEthernet1/0
1.1.1.1           1   FULL/BDR        00:00:35    12.12.12.1      FastEthernet0/1

R2#sh ip bgp vpnv4 all
BGP table version is 71, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf cust1)
*> 1.1.1.1/32       12.12.12.1              11         32768 ?
*>i8.8.8.8/32       4.4.4.4                  0    100      0 2 ?
*> 10.1.1.0/24      12.12.12.1              20         32768 ?
*> 12.12.12.0/24    0.0.0.0                  0         32768 ?
*>i40.1.1.0/24      4.4.4.4                  0    100      0 2 ?
*>i78.78.78.0/24    4.4.4.4                  0    100      0 2 ?
Route Distinguisher: 2:2
*>i8.8.8.8/32       4.4.4.4                  0    100      0 2 ?
*>i40.1.1.0/24      4.4.4.4                  0    100      0 2 ?
*>i78.78.78.0/24    4.4.4.4                  0    100      0 2 ?
R2#

R2#       sh ip bgp vpnv4 all summary
BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 17, main routing table version 17
8 network entries using 1096 bytes of memory
8 path entries using 544 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP extended community entries using 64 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2596 total bytes of memory
BGP activity 8/0 prefixes, 8/0 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4     1     128     130       17    0    0 02:01:39        5

R2#show mpls ldp neighbor
    Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 2.2.2.2:0
        TCP connection: 3.3.3.3.22256 - 2.2.2.2.646
        State: Oper; Msgs sent/rcvd: 48/49; Downstream
        Up time: 00:35:48
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 23.23.23.3
        Addresses bound to peer LDP Ident:
          23.23.23.3      3.3.3.3         34.34.34.3

R2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     3.3.3.3/32        0          Fa1/0      23.23.23.3
17     Pop tag     34.34.34.0/24     0          Fa1/0      23.23.23.3
18     17          4.4.4.4/32        0          Fa1/0      23.23.23.3
19     Untagged    1.1.1.1/32[V]     0          Fa0/1      12.12.12.1
20     Untagged    10.1.1.0/24[V]    0          Fa0/1      12.12.12.1

21     Aggregate   12.12.12.0/24[V]  15552

R3:-

R3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           1   FULL/DR         00:00:39    34.34.34.4      FastEthernet2/0
2.2.2.2           1   FULL/BDR        00:00:36    23.23.23.2      FastEthernet1/0

R3#show mpls ldp neighbor
    Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 3.3.3.3:0
        TCP connection: 2.2.2.2.646 - 3.3.3.3.22256
        State: Oper; Msgs sent/rcvd: 51/50; Downstream
        Up time: 00:37:31
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 23.23.23.2
        Addresses bound to peer LDP Ident:
          23.23.23.2      2.2.2.2
    Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 3.3.3.3:0
        TCP connection: 4.4.4.4.11554 - 3.3.3.3.646
        State: Oper; Msgs sent/rcvd: 51/51; Downstream
        Up time: 00:37:29
        LDP discovery sources:
          FastEthernet2/0, Src IP addr: 34.34.34.4
        Addresses bound to peer LDP Ident:
          34.34.34.4      4.4.4.4

R3#show mpls forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     2.2.2.2/32        47465      Fa1/0      23.23.23.2
17     Pop tag     4.4.4.4/32        33636      Fa2/0      34.34.34.4

R4:-

R4#        show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:31    34.34.34.3      FastEthernet2/0

R4#sh ip bgp vpnv4 all summary
BGP router identifier 4.4.4.4, local AS number 1
BGP table version is 96, main routing table version 96
6 network entries using 912 bytes of memory
6 path entries using 312 bytes of memory
6/6 BGP path/bestpath attribute entries using 792 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 240 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2280 total bytes of memory
BGP activity 25/19 prefixes, 43/37 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4            1     135     153       96    0    0 02:08:23        3
45.45.45.5      4            2     150     148       96    0    0 02:08:09        3

R4#show ip bgp vpnv4 all
BGP table version is 96, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i1.1.1.1/32       2.2.2.2                 11    100      0 ?
*>i10.1.1.0/24      2.2.2.2                 20    100      0 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 ?
Route Distinguisher: 2:2
*> 8.8.8.8/32       45.45.45.5                             0 2 ?
*> 40.1.1.0/24      45.45.45.5                             0 2 ?
*> 78.78.78.0/24    45.45.45.5                             0 2 ?

R4#sh ip bgp summary
BGP router identifier 4.4.4.4, local AS number 1
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4            1     135     154        1    0    0 02:08:55        0
45.45.45.5      4            2     150     149        1    0    0 02:08:41        0

R4#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  3.3.3.3/32       0             Fa2/0      34.34.34.3
17         16         2.2.2.2/32       0             Fa2/0      34.34.34.3
18         Pop Label  23.23.23.0/24    0             Fa2/0      34.34.34.3
19         27         2:2:40.1.1.0/24  4232          Fa3/0      45.45.45.5
21         20         1:1:10.1.1.0/24  0             Fa2/0      34.34.34.3
22         19         1:1:1.1.1.1/32   0             Fa2/0      34.34.34.3
23         21         1:1:12.12.12.0/24   
                                       10280         Fa2/0      34.34.34.3
24         Pop Label  45.45.45.5/32    0             Fa3/0      45.45.45.5
25         26         2:2:78.78.78.0/24   
                                       0             Fa3/0      45.45.45.5
26         18         2:2:8.8.8.8/32   0             Fa3/0      45.45.45.5

R4#


R5:-

R5#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         22         1:1:1.1.1.1/32   0             Fa3/0      45.45.45.4
17         23         1:1:12.12.12.0/24   
                                       10024         Fa3/0      45.45.45.4
18         16         2:2:8.8.8.8/32   0             Fa1/0      56.56.56.6
19         Pop Label  45.45.45.4/32    0             Fa3/0      45.45.45.4
20         21         1:1:10.1.1.0/24  0             Fa3/0      45.45.45.4
21         Pop Label  6.6.6.6/32       0             Fa1/0      56.56.56.6
22         Pop Label  67.67.67.0/24    0             Fa1/0      56.56.56.6
23         16         7.7.7.7/32       0             Fa1/0      56.56.56.6
26         18         2:2:78.78.78.0/24   
                                       0             Fa1/0      56.56.56.6
27         17         2:2:40.1.1.0/24  5716          Fa1/0      56.56.56.6

R5#sh ip bgp vpnv4 all
BGP table version is 106, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*> 1.1.1.1/32       45.45.45.4                             0 1 ?
*> 10.1.1.0/24      45.45.45.4                             0 1 ?
*> 12.12.12.0/24    45.45.45.4                             0 1 ?
Route Distinguisher: 2:2
*>i8.8.8.8/32       7.7.7.7                  2    100      0 ?
*>i40.1.1.0/24      7.7.7.7                  2    100      0 ?
*>i78.78.78.0/24    7.7.7.7                  0    100      0 ?

R5#sh ip bgp vpnv4 all summary
BGP router identifier 5.5.5.5, local AS number 2
BGP table version is 106, main routing table version 106
6 network entries using 912 bytes of memory
6 path entries using 312 bytes of memory
4/4 BGP path/bestpath attribute entries using 528 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 810 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2586 total bytes of memory
BGP activity 22/16 prefixes, 45/39 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
7.7.7.7         4            2     138     151      106    0    0 02:11:42        3
45.45.45.4      4            1     152     153      106    0    0 02:11:39        3

R5#sh ip bgp summary
BGP router identifier 5.5.5.5, local AS number 2
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
7.7.7.7         4            2     138     152        1    0    0 02:11:59        0
45.45.45.4      4            1     152     154        1    0    0 02:11:56        0

R5#show ip route vrf cust1
% IP routing table vrf cust1 does not exist

R5#show mpls ldp neighbor
    Peer LDP Ident: 6.6.6.6:0; Local LDP Ident 5.5.5.5:0
        TCP connection: 6.6.6.6.58774 - 5.5.5.5.646
        State: Oper; Msgs sent/rcvd: 233/229; Downstream
        Up time: 03:15:13
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 56.56.56.6
        Addresses bound to peer LDP Ident:
          56.56.56.6      6.6.6.6         67.67.67.6
R6:-

R6#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
7.7.7.7           1   FULL/DR         00:00:34    67.67.67.7      FastEthernet2/0
5.5.5.5           1   FULL/DR         00:00:32    56.56.56.5      FastEthernet1/0
R6#show mpls ldp neighbor
    Peer LDP Ident: 5.5.5.5:0; Local LDP Ident 6.6.6.6:0
        TCP connection: 5.5.5.5.646 - 6.6.6.6.58774
        State: Oper; Msgs sent/rcvd: 230/234; Downstream
        Up time: 03:16:09
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 56.56.56.5
        Addresses bound to peer LDP Ident:
          56.56.56.5      5.5.5.5         45.45.45.5
    Peer LDP Ident: 7.7.7.7:0; Local LDP Ident 6.6.6.6:0
        TCP connection: 7.7.7.7.21505 - 6.6.6.6.646
        State: Oper; Msgs sent/rcvd: 231/233; Downstream
        Up time: 03:16:01
        LDP discovery sources:
          FastEthernet2/0, Src IP addr: 67.67.67.7
        Addresses bound to peer LDP Ident:
          67.67.67.7      7.7.7.7

R6#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  7.7.7.7/32       45976         Fa2/0      67.67.67.7
17         Pop Label  5.5.5.5/32       45875         Fa1/0      56.56.56.5

R7#

R7#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Untagged    8.8.8.8/32[V]     0          Fa0/1      78.78.78.8
17     Untagged    40.1.1.0/24[V]    7824       Fa0/1      78.78.78.8
18     Aggregate   78.78.78.0/24[V]  0
19     Pop tag     56.56.56.0/24     0          Fa2/0      67.67.67.6
20     17          5.5.5.5/32        0          Fa2/0      67.67.67.6
21     Pop tag     6.6.6.6/32        0          Fa2/0      67.67.67.6

R7#show ip bgp vpnv4 all summary
BGP router identifier 7.7.7.7, local AS number 2
BGP table version is 85, main routing table version 85
9 network entries using 1233 bytes of memory
9 path entries using 612 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 810 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3299 total bytes of memory
BGP activity 22/13 prefixes, 43/34 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
5.5.5.5         4     2     258     226       85    0    0 02:14:34        3

R7#sh ip bgp vpnv4 all
BGP table version is 85, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i1.1.1.1/32       5.5.5.5                  0    100      0 1 ?
*>i10.1.1.0/24      5.5.5.5                  0    100      0 1 ?
*>i12.12.12.0/24    5.5.5.5                  0    100      0 1 ?
Route Distinguisher: 2:2 (default for vrf cust1)
*>i1.1.1.1/32       5.5.5.5                  0    100      0 1 ?
*> 8.8.8.8/32       78.78.78.8               2         32768 ?
*>i10.1.1.0/24      5.5.5.5                  0    100      0 1 ?
*>i12.12.12.0/24    5.5.5.5                  0    100      0 1 ?
*> 40.1.1.0/24      78.78.78.8               2         32768 ?
*> 78.78.78.0/24    0.0.0.0                  0         32768 ?

R7#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Untagged    8.8.8.8/32[V]     0          Fa0/1      78.78.78.8
17     Untagged    40.1.1.0/24[V]    7824       Fa0/1      78.78.78.8
18     Aggregate   78.78.78.0/24[V]  0
19     Pop tag     56.56.56.0/24     0          Fa2/0      67.67.67.6
20     17          5.5.5.5/32        0          Fa2/0      67.67.67.6
21     Pop tag     6.6.6.6/32        0          Fa2/0      67.67.67.6

R7#

R8:-

R8#sh ip eigrp neighbors
IP-EIGRP neighbors for process 2
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   78.78.78.7              Fa0/1             12 02:08:12  833  5000  0  15

R8#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
D EX    1.1.1.1 [170/2560025856] via 78.78.78.7, 02:15:04, FastEthernet0/1
     8.0.0.0/32 is subnetted, 1 subnets
C       8.8.8.8 is directly connected, Loopback0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.1.1.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
D EX    10.1.1.0 [170/2560025856] via 78.78.78.7, 02:15:04, FastEthernet0/1
     78.0.0.0/24 is subnetted, 1 subnets
C       78.78.78.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
D EX    12.12.12.0 [170/2560025856] via 78.78.78.7, 02:15:06, FastEthernet0/1

PC4:-
PC4> ping 10.1.1.10
84 bytes from 10.1.1.10 icmp_seq=1 ttl=56 time=249.603 ms
84 bytes from 10.1.1.10 icmp_seq=2 ttl=56 time=187.203 ms
84 bytes from 10.1.1.10 icmp_seq=3 ttl=56 time=218.403 ms
84 bytes from 10.1.1.10 icmp_seq=4 ttl=56 time=187.202 ms
84 bytes from 10.1.1.10 icmp_seq=5 ttl=56 time=202.803 ms



No comments:

Post a Comment