Saturday 11 March 2017

Inter-AS option A - MPLS






PC1:-

PC1> show ip

NAME        : PC1[1]
IP/MASK     : 10.1.1.10/24
GATEWAY     : 10.1.1.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10000
RHOST:PORT  : 127.0.0.1:10001
MTU:        : 1500

R1:-

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

interface FastEthernet0/0
 description *** Connected to PC1***
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet0/1
 description *** Connected to R2 ***
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto

router ospf 100
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0

R2:-

ip vrf cust1
 rd 1:1
 route-target export 1:1
 route-target import 1:1

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface FastEthernet0/1
description *** Connected to R1 ***
  ip vrf forwarding cust1
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet1/0
description *** Connected to R3 ***
 ip address 23.23.23.2 255.255.255.0
 speed 100
 full-duplex
 mpls ip

router ospf 100 vrf cust1
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 12.12.12.2 0.0.0.0 area 0

router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0

router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 1
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary

 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute ospf 100 vrf cust1 match internal external 1 external 2
  no synchronization
 exit-address-family

mpls ldp router-id Loopback0 force

R3:-


interface Loopback0
 ip address 3.3.3.3 255.255.255.255

interface FastEthernet1/0
description *** Connected to R2 ***
 ip address 23.23.23.3 255.255.255.0
 speed 100
 full-duplex
 mpls ip

interface FastEthernet2/0
description *** Connected to R4 ***
 ip address 34.34.34.3 255.255.255.0
 duplex auto
 speed auto
 mpls ip

router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0

mpls ldp router-id Loopback0 force

PC2:-

PC2> show ip

NAME        : PC2[1]
IP/MASK     : 20.1.1.10/24
GATEWAY     : 20.1.1.1
DNS         :
MAC         : 00:50:79:66:68:01
LPORT       : 10011
RHOST:PORT  : 127.0.0.1:10010
MTU:        : 1500

R4:-

ip vrf cust1
 rd 1:1
 route-target export 1:1
 route-target import 1:1

interface Loopback0
 ip address 4.4.4.4 255.255.255.255

interface FastEthernet0/0
description *** Connected to PC2 ***
 ip vrf forwarding cust1
 ip address 20.1.1.1 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet2/0
description *** Connected to R3**
 ip address 34.34.34.4 255.255.255.0
 duplex auto
 speed auto
 mpls ip

interface FastEthernet3/0
description *** Connected to R5***
 ip vrf forwarding cust1
 ip address 45.45.45.4 255.255.255.0
 duplex auto
 speed auto

router ospf 100 vrf cust1
 log-adjacency-changes
 network 20.1.1.1 0.0.0.0 area 0

router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 34.34.34.4 0.0.0.0 area 0

router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary

 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
  neighbor 45.45.45.5 remote-as 2
  neighbor 45.45.45.5 activate
  no synchronization
  network 20.1.1.0 mask 255.255.255.0
 exit-address-family

mpls ldp router-id Loopback0 force


R5:-

ip vrf cust1
 rd 2:2
 route-target export 200:1
 route-target import 200:1

interface Loopback0
 ip address 5.5.5.5 255.255.255.255

interface FastEthernet0/0
description *** Connected to PC3
 ip vrf forwarding cust1
 ip address 30.1.1.1 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet1/0
description *** Connected to R6 ***
 ip address 56.56.56.5 255.255.255.0
 speed 100
 full-duplex
 mpls ip

interface FastEthernet3/0
description *** Connected to R4**
 ip vrf forwarding cust1
 ip address 45.45.45.5 255.255.255.0
 duplex auto
 speed auto

router eigrp 2
 auto-summary
  address-family ipv4 vrf cust1
  redistribute bgp 2 metric 1 1 1 1 1
  network 30.1.1.1 0.0.0.0
  auto-summary
  autonomous-system 2
 exit-address-family

router ospf 2
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 56.56.56.5 0.0.0.0 area 0

router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 7.7.7.7 remote-as 2
 neighbor 7.7.7.7 update-source Loopback0
 no auto-summary

 address-family vpnv4
  neighbor 7.7.7.7 activate
  neighbor 7.7.7.7 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute eigrp 2
  neighbor 45.45.45.4 remote-as 1
  neighbor 45.45.45.4 activate
  no synchronization
  network 30.1.1.0 mask 255.255.255.0
 exit-address-family

mpls ldp router-id Loopback0 force

       
R6:-

interface Loopback0
 ip address 6.6.6.6 255.255.255.255

interface FastEthernet1/0
description *** Connected to R5***
 ip address 56.56.56.6 255.255.255.0
 speed 100
 full-duplex
 mpls ip

interface FastEthernet2/0
description *** Connected to R6***
 ip address 67.67.67.6 255.255.255.0
 duplex auto
 speed auto
 mpls ip

router ospf 2
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 56.56.56.6 0.0.0.0 area 0
 network 67.67.67.6 0.0.0.0 area 0


R7:-

rd 2:2
 route-target export 200:1
 route-target import 200:1

interface Loopback0
 ip address 7.7.7.7 255.255.255.255


interface FastEthernet0/1
description *** Connected to R8**
 ip vrf forwarding cust1
 ip address 78.78.78.7 255.255.255.0
 duplex auto
 speed auto

interface FastEthernet2/0
description *** Connected to R6***
 ip address 67.67.67.7 255.255.255.0
 duplex auto
 speed auto
 mpls ip

router eigrp 1
 auto-summary
  address-family ipv4 vrf cust1
  redistribute bgp 2 metric 1 1 1 1 1
  network 78.78.78.7 0.0.0.0
  auto-summary
  autonomous-system 2
 exit-address-family

router ospf 2
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 67.67.67.7 0.0.0.0 area 0

router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 2
 neighbor 5.5.5.5 update-source Loopback0
 no auto-summary

 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family

 address-family ipv4 vrf cust1
  redistribute eigrp 2 metric 2
  default-metric 1
  no synchronization
 exit-address-family



R8:-

interface Loopback0
 ip address 8.8.8.8 255.255.255.255

interface FastEthernet0/0
description *** Connected to PC4*
 ip address 40.1.1.1 255.255.255.0
 duplex auto
 speed auto


interface FastEthernet0/1
description *** Connected to R7*
 ip address 78.78.78.8 255.255.255.0
 duplex auto
 speed auto

router eigrp 2
 network 8.8.8.8 0.0.0.0
 network 40.1.1.1 0.0.0.0
 network 40.1.1.0 0.0.0.255
 network 78.78.78.8 0.0.0.0
 no auto-summary

PC4:-

PC4> show ip

NAME        : PC4[1]
IP/MASK     : 40.1.1.10/24
GATEWAY     : 40.1.1.1
DNS         :
MAC         : 00:50:79:66:68:03
LPORT       : 10019
RHOST:PORT  : 127.0.0.1:10018
MTU:        : 1500

PC1:-

PC1> ping 20.1.1.10
84 bytes from 20.1.1.10 icmp_seq=1 ttl=60 time=109.200 ms
84 bytes from 20.1.1.10 icmp_seq=2 ttl=60 time=109.200 ms
84 bytes from 20.1.1.10 icmp_seq=3 ttl=60 time=109.200 ms
84 bytes from 20.1.1.10 icmp_seq=4 ttl=60 time=93.600 ms
84 bytes from 20.1.1.10 icmp_seq=5 ttl=60 time=156.000 ms

PC1> ping 30.1.1.10
84 bytes from 30.1.1.10 icmp_seq=1 ttl=59 time=124.800 ms
84 bytes from 30.1.1.10 icmp_seq=2 ttl=59 time=124.800 ms
84 bytes from 30.1.1.10 icmp_seq=3 ttl=59 time=124.800 ms
84 bytes from 30.1.1.10 icmp_seq=4 ttl=59 time=109.200 ms
84 bytes from 30.1.1.10 icmp_seq=5 ttl=59 time=109.200 ms

PC1> ping 40.1.1.10
84 bytes from 40.1.1.10 icmp_seq=1 ttl=56 time=171.600 ms
84 bytes from 40.1.1.10 icmp_seq=2 ttl=56 time=218.400 ms
84 bytes from 40.1.1.10 icmp_seq=3 ttl=56 time=187.200 ms
84 bytes from 40.1.1.10 icmp_seq=4 ttl=56 time=234.000 ms
84 bytes from 40.1.1.10 icmp_seq=5 ttl=56 time=202.800 ms


R1:-

R1#       sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     20.0.0.0/24 is subnetted, 1 subnets
O E2    20.1.1.0 [110/1] via 12.12.12.2, 01:58:03, FastEthernet0/1
     8.0.0.0/32 is subnetted, 1 subnets
O E2    8.8.8.8 [110/1] via 12.12.12.2, 01:39:58, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
O E2    40.1.1.0 [110/1] via 12.12.12.2, 01:39:58, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
     78.0.0.0/24 is subnetted, 1 subnets
O E2    78.78.78.0 [110/1] via 12.12.12.2, 01:40:00, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/1
     30.0.0.0/24 is subnetted, 1 subnets
O E2    30.1.1.0 [110/1] via 12.12.12.2, 01:40:02, FastEthernet0/1

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
12.12.12.2        1   FULL/DR         00:00:36    12.12.12.2      FastEthernet0/1

R2:-

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:35    23.23.23.3      FastEthernet1/0
1.1.1.1           1   FULL/BDR        00:00:35    12.12.12.1      FastEthernet0/1


R2#show ip route vrf cust1

Routing Table: cust1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/11] via 12.12.12.1, 02:01:37, FastEthernet0/1
     20.0.0.0/24 is subnetted, 1 subnets
B       20.1.1.0 [200/0] via 4.4.4.4, 02:00:56
     8.0.0.0/32 is subnetted, 1 subnets
B       8.8.8.8 [200/0] via 4.4.4.4, 01:42:41
     40.0.0.0/24 is subnetted, 1 subnets
B       40.1.1.0 [200/0] via 4.4.4.4, 01:42:41
     10.0.0.0/24 is subnetted, 1 subnets
O       10.1.1.0 [110/20] via 12.12.12.1, 02:01:37, FastEthernet0/1
     78.0.0.0/24 is subnetted, 1 subnets
B       78.78.78.0 [200/0] via 4.4.4.4, 01:42:44
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/1
     30.0.0.0/24 is subnetted, 1 subnets
B       30.1.1.0 [200/0] via 4.4.4.4, 01:42:44

R2#       sh ip bgp vpnv4 all summary
BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 17, main routing table version 17
8 network entries using 1096 bytes of memory
8 path entries using 544 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP extended community entries using 64 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2596 total bytes of memory
BGP activity 8/0 prefixes, 8/0 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4     1     128     130       17    0    0 02:01:39        5

R2#show ip bgp vpnv4 all
BGP table version is 17, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf cust1)
*> 1.1.1.1/32       12.12.12.1              11         32768 ?
*>i8.8.8.8/32       4.4.4.4                  0    100      0 2 ?
*> 10.1.1.0/24      12.12.12.1              20         32768 ?
*> 12.12.12.0/24    0.0.0.0                  0         32768 ?
*>i20.1.1.0/24      4.4.4.4                  0    100      0 i
*>i30.1.1.0/24      4.4.4.4                  0    100      0 2 i
*>i40.1.1.0/24      4.4.4.4                  0    100      0 2 ?
*>i78.78.78.0/24    4.4.4.4                  0    100      0 2 ?

R2#show mpls ldp neighbor
    Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 2.2.2.2:0
        TCP connection: 3.3.3.3.22256 - 2.2.2.2.646
        State: Oper; Msgs sent/rcvd: 48/49; Downstream
        Up time: 00:35:48
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 23.23.23.3
        Addresses bound to peer LDP Ident:
          23.23.23.3      3.3.3.3         34.34.34.3

R3:-

R3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           1   FULL/DR         00:00:39    34.34.34.4      FastEthernet2/0
2.2.2.2           1   FULL/BDR        00:00:36    23.23.23.2      FastEthernet1/0

R3#show mpls ldp neighbor
    Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 3.3.3.3:0
        TCP connection: 2.2.2.2.646 - 3.3.3.3.22256
        State: Oper; Msgs sent/rcvd: 51/50; Downstream
        Up time: 00:37:31
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 23.23.23.2
        Addresses bound to peer LDP Ident:
          23.23.23.2      2.2.2.2
    Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 3.3.3.3:0
        TCP connection: 4.4.4.4.11554 - 3.3.3.3.646
        State: Oper; Msgs sent/rcvd: 51/51; Downstream
        Up time: 00:37:29
        LDP discovery sources:
          FastEthernet2/0, Src IP addr: 34.34.34.4
        Addresses bound to peer LDP Ident:
          34.34.34.4      4.4.4.4
R3#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     2.2.2.2/32        12381      Fa1/0      23.23.23.2
17     Pop tag     4.4.4.4/32        12575      Fa2/0      34.34.34.4
R3#

PC2:-


R4:-


R4#        show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:31    34.34.34.3      FastEthernet2/0

R4#show ip bgp vpnv4 all summary
BGP router identifier 4.4.4.4, local AS number 1
BGP table version is 13, main routing table version 13
8 network entries using 1096 bytes of memory
8 path entries using 544 bytes of memory
9/6 BGP path/bestpath attribute entries using 1116 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP extended community entries using 64 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2844 total bytes of memory
BGP activity 8/0 prefixes, 8/0 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4     1     134     132       13    0    0 02:05:15        3
45.45.45.5      4     2     114     114       13    0    0 01:46:30        4

R4#show ip bgp vpnv4 all
BGP table version is 13, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf cust1)
*>i1.1.1.1/32       2.2.2.2                 11    100      0 ?
*> 8.8.8.8/32       45.45.45.5                             0 2 ?
*>i10.1.1.0/24      2.2.2.2                 20    100      0 ?
*>i12.12.12.0/24    2.2.2.2                  0    100      0 ?
*> 20.1.1.0/24      0.0.0.0                  0         32768 i
*> 30.1.1.0/24      45.45.45.5               0             0 2 i
*> 40.1.1.0/24      45.45.45.5                             0 2 ?
*> 78.78.78.0/24    45.45.45.5                             0 2 ?

R4#sh ip bgp summary
BGP router identifier 4.4.4.4, local AS number 1
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4     1     134     132        1    0    0 02:05:28        0

R5:-

R5#                  sh ip bgp vpnv4 all
BGP table version is 25, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 2:2 (default for vrf cust1)
*> 1.1.1.1/32       45.45.45.4                             0 1 ?
*>i8.8.8.8/32       7.7.7.7                  2    100      0 ?
*> 10.1.1.0/24      45.45.45.4                             0 1 ?
*> 12.12.12.0/24    45.45.45.4                             0 1 ?
*> 20.1.1.0/24      45.45.45.4               0             0 1 i
*> 30.1.1.0/24      0.0.0.0                  0         32768 i
*>i40.1.1.0/24      7.7.7.7                  2    100      0 ?
*>i78.78.78.0/24    7.7.7.7                  0    100      0 ?

R5#                  sh ip bgp vpnv4 all summary
BGP router identifier 5.5.5.5, local AS number 2
BGP table version is 25, main routing table version 25
8 network entries using 1096 bytes of memory
8 path entries using 544 bytes of memory
9/6 BGP path/bestpath attribute entries using 1116 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 204 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2984 total bytes of memory
BGP activity 8/0 prefixes, 12/4 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
7.7.7.7         4     2     145     133       25    0    0 02:06:28        3
45.45.45.4      4     1     115     115       25    0    0 01:47:49        4


R5#sh ip bgp summary
BGP router identifier 5.5.5.5, local AS number 2
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
7.7.7.7         4     2     145     133        1    0    0 02:06:34        0

R5#show ip route vrf cust1

Routing Table: cust1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/0] via 45.45.45.4, 01:48:02
     20.0.0.0/24 is subnetted, 1 subnets
B       20.1.1.0 [20/0] via 45.45.45.4, 01:48:02
     8.0.0.0/32 is subnetted, 1 subnets
B       8.8.8.8 [200/2] via 7.7.7.7, 01:59:05
     40.0.0.0/24 is subnetted, 1 subnets
B       40.1.1.0 [200/2] via 7.7.7.7, 01:59:05
     10.0.0.0/24 is subnetted, 1 subnets
B       10.1.1.0 [20/0] via 45.45.45.4, 01:48:02
     78.0.0.0/24 is subnetted, 1 subnets
B       78.78.78.0 [200/0] via 7.7.7.7, 02:05:59
     12.0.0.0/24 is subnetted, 1 subnets
B       12.12.12.0 [20/0] via 45.45.45.4, 01:48:05
     45.0.0.0/24 is subnetted, 1 subnets
C       45.45.45.0 is directly connected, FastEthernet3/0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.1.1.0 is directly connected, FastEthernet0/0

R5#show mpls ldp neighbor
    Peer LDP Ident: 6.6.6.6:0; Local LDP Ident 5.5.5.5:0
        TCP connection: 6.6.6.6.60873 - 5.5.5.5.646
        State: Oper; Msgs sent/rcvd: 154/153; Downstream
        Up time: 02:06:57
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 56.56.56.6
        Addresses bound to peer LDP Ident:

R6:-

R6#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
7.7.7.7           1   FULL/DR         00:00:37    67.67.67.7      FastEthernet2/0
5.5.5.5           1   FULL/BDR        00:00:39    56.56.56.5      FastEthernet1/0

R6#show mpls ldp neighbor
    Peer LDP Ident: 5.5.5.5:0; Local LDP Ident 6.6.6.6:0
        TCP connection: 5.5.5.5.646 - 6.6.6.6.60873
        State: Oper; Msgs sent/rcvd: 159/160; Downstream
        Up time: 02:11:51
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 56.56.56.5
        Addresses bound to peer LDP Ident:
          56.56.56.5      5.5.5.5
    Peer LDP Ident: 7.7.7.7:0; Local LDP Ident 6.6.6.6:0
        TCP connection: 7.7.7.7.40722 - 6.6.6.6.646
        State: Oper; Msgs sent/rcvd: 60/61; Downstream
        Up time: 00:46:11
        LDP discovery sources:
          FastEthernet2/0, Src IP addr: 67.67.67.7
        Addresses bound to peer LDP Ident:
          67.67.67.7      7.7.7.7


R7#

R7#show ip bgp vpnv4 all summary
BGP router identifier 7.7.7.7, local AS number 2
BGP table version is 29, main routing table version 29
8 network entries using 1096 bytes of memory
8 path entries using 544 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
4 BGP extended community entries using 204 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2736 total bytes of memory
BGP activity 8/0 prefixes, 12/4 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
5.5.5.5         4     2     140     152       29    0    0 02:13:06        5

R7#sh ip bgp vpnv4 all
BGP table version is 29, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 2:2 (default for vrf cust1)
*>i1.1.1.1/32       5.5.5.5                  0    100      0 1 ?
*> 8.8.8.8/32       78.78.78.8               2         32768 ?
*>i10.1.1.0/24      5.5.5.5                  0    100      0 1 ?
*>i12.12.12.0/24    5.5.5.5                  0    100      0 1 ?
*>i20.1.1.0/24      5.5.5.5                  0    100      0 1 i
*>i30.1.1.0/24      5.5.5.5                  0    100      0 i
*> 40.1.1.0/24      78.78.78.8               2         32768 ?
*> 78.78.78.0/24    0.0.0.0                  0         32768 ?


R8:-

R8#sh ip eigrp neighbors
IP-EIGRP neighbors for process 2
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   78.78.78.7              Fa0/1             12 02:08:12  833  5000  0  15

R8#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
D EX    1.1.1.1 [170/2560025856] via 78.78.78.7, 01:56:26, FastEthernet0/1
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/2560025856] via 78.78.78.7, 01:56:26, FastEthernet0/1
     8.0.0.0/32 is subnetted, 1 subnets
C       8.8.8.8 is directly connected, Loopback0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.1.1.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
D EX    10.1.1.0 [170/2560025856] via 78.78.78.7, 01:56:26, FastEthernet0/1
     78.0.0.0/24 is subnetted, 1 subnets
C       78.78.78.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
D EX    12.12.12.0 [170/2560025856] via 78.78.78.7, 01:56:29, FastEthernet0/1
     30.0.0.0/24 is subnetted, 1 subnets
D       30.1.1.0 [90/307200] via 78.78.78.7, 01:56:29, FastEthernet0/1
R8#

Verification:-

PC4:-
PC4> ping 10.1.1.10
84 bytes from 10.1.1.10 icmp_seq=1 ttl=56 time=249.603 ms
84 bytes from 10.1.1.10 icmp_seq=2 ttl=56 time=187.203 ms
84 bytes from 10.1.1.10 icmp_seq=3 ttl=56 time=218.403 ms
84 bytes from 10.1.1.10 icmp_seq=4 ttl=56 time=187.202 ms
84 bytes from 10.1.1.10 icmp_seq=5 ttl=56 time=202.803 ms


PC4> ping 20.1.1.10
84 bytes from 20.1.1.10 icmp_seq=1 ttl=59 time=124.802 ms
84 bytes from 20.1.1.10 icmp_seq=2 ttl=59 time=124.801 ms
84 bytes from 20.1.1.10 icmp_seq=3 ttl=59 time=124.802 ms
84 bytes from 20.1.1.10 icmp_seq=4 ttl=59 time=93.601 ms
84 bytes from 20.1.1.10 icmp_seq=5 ttl=59 time=140.402 ms


PC4> ping 30.1.1.10
84 bytes from 30.1.1.10 icmp_seq=1 ttl=60 time=124.802 ms
84 bytes from 30.1.1.10 icmp_seq=2 ttl=60 time=109.201 ms
84 bytes from 30.1.1.10 icmp_seq=3 ttl=60 time=124.802 ms
84 bytes from 30.1.1.10 icmp_seq=4 ttl=60 time=93.601 ms
84 bytes from 30.1.1.10 icmp_seq=5 ttl=60 time=78.001 ms


No comments:

Post a Comment