External route can only be summarized on ASBR only.
R1:-
interface Loopback0
ip address 1.1.1.1
255.255.255.255
interface FastEthernet0/0
description ***
Connected to R2***
ip address
12.12.12.1 255.255.255.0
no shut
interface FastEthernet1/0
description *** Connected to LAN1***
ip address
10.1.1.17 255.255.255.240
no shut
interface FastEthernet2/0
description *** Connected to LAN2***
ip address
10.1.1.1 255.255.255.240
no shut
interface FastEthernet3/0
description *** Connected to LAN3***
ip address
10.1.1.33 255.255.255.240
no shut
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1
0.0.0.0 area 1
network 10.1.1.1
0.0.0.0 area 1
network 10.1.1.17
0.0.0.0 area 1
network 10.1.1.33
0.0.0.0 area 1
network 12.12.12.1
0.0.0.0 area 1
R2:-
interface FastEthernet0/0
description *** Connected to R1***
ip address
12.12.12.2 255.255.255.0
no shut
interface FastEthernet0/1
description *** Connected to R3***
ip address
23.23.23.2 255.255.255.0
no shut
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2
0.0.0.0 area 0
network 12.12.12.2
0.0.0.0 area 1
network 23.23.23.2
0.0.0.0 area 0
R3:-
interface Loopback0
ip address 3.3.3.3
255.255.255.255
interface FastEthernet0/0
description *** Connected to LAN1***
ip address
30.1.1.1 255.255.255.240
no shut
interface FastEthernet0/1
description *** Connected to R2***
ip address
23.23.23.3 255.255.255.0
no shut
interface FastEthernet1/0
description *** Connected to R4***
ip address
34.34.34.3 255.255.255.0
no shut
interface FastEthernet2/0
description *** Connected to LAN2***
ip address
30.1.1.17 255.255.255.240
no shut
interface FastEthernet3/0
description *** Connected to LAN3***
ip address
30.1.1.33 255.255.255.240
no shut
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
summary-address 30.1.1.0
255.255.255.0 \\Summarization of small /28 subnet
to /24
redistribute
connected subnets
network 3.3.3.3
0.0.0.0 area 0
network 23.23.23.3
0.0.0.0 area 0
network 34.34.34.3
0.0.0.0 area 0
R4:-
interface FastEthernet0/0
description *** Connected to R5***
ip address
45.45.45.4 255.255.255.0
no shut
interface FastEthernet1/0
description *** Connected to R3***
ip address
34.34.34.4 255.255.255.0
no shut
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 34.34.34.4
0.0.0.0 area 0
network 45.45.45.4
0.0.0.0 area 2
R5:-
interface FastEthernet0/0
description ***
Connected to R4***
ip address
45.45.45.5 255.255.255.0
no shut
interface FastEthernet2/0
description *** Connected to LAN1***
ip address
50.1.1.1 255.255.255.0
no shut
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5
0.0.0.0 area 2
network 45.45.45.5
0.0.0.0 area 2
network 50.1.1.1
0.0.0.0 area 2
Verification:-
R1:-
R1#sh ip ospf neighbor
Neighbor ID
Pri State Dead Time Address Interface
2.2.2.2
1 FULL/BDR 00:00:37 12.12.12.2 FastEthernet0/0
R1#sh ip route ospf
34.0.0.0/24 is
subnetted, 1 subnets
O IA 34.34.34.0 [110/12] via 12.12.12.2, 05:21:44,
FastEthernet0/0
50.0.0.0/24 is
subnetted, 1 subnets
O IA 50.1.1.0
[110/14] via 12.12.12.2, 05:21:44, FastEthernet0/0
3.0.0.0/32 is
subnetted, 1 subnets
O IA 3.3.3.3
[110/12] via 12.12.12.2, 03:31:23, FastEthernet0/0
23.0.0.0/24 is
subnetted, 1 subnets
O IA 23.23.23.0
[110/11] via 12.12.12.2, 05:21:44, FastEthernet0/0
45.0.0.0/24 is
subnetted, 1 subnets
O IA 45.45.45.0
[110/13] via 12.12.12.2, 05:21:44, FastEthernet0/0
30.0.0.0/24 is
subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 12.12.12.2,
00:04:18, FastEthernet0/0 \\Summarized /24 route
R1#sh ip route 30.1.1.1
Routing
entry for 30.1.1.0/24
Known via
"ospf 1", distance 110, metric 20, type extern 2, forward metric 11
Last update from
12.12.12.2 on FastEthernet0/0, 00:05:57 ago
Routing
Descriptor Blocks:
* 12.12.12.2,
from 3.3.3.3, 00:05:57 ago, via FastEthernet0/0
Route metric
is 20, traffic share count is 1
R1#sh ip ospf database
OSPF
Router with ID (1.1.1.1) (Process ID 1)
Router Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum Link count
1.1.1.1
1.1.1.1 994 0x80000011 0x008FC8 5
2.2.2.2 2.2.2.2 1037 0x8000000F 0x003395 1
Net
Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum
12.12.12.1
1.1.1.1 1501 0x8000000D 0x0034C4
Summary Net Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
2.2.2.2 540 0x80000007 0x00CA56
23.23.23.0
2.2.2.2 1037 0x8000000D 0x00FFE2
34.34.34.0
2.2.2.2 1037 0x8000000D 0x007C44
45.45.45.0
2.2.2.2 1037 0x8000000D 0x00F8A5
50.1.1.0
2.2.2.2 1037 0x8000000D 0x00B937
Summary ASB Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
2.2.2.2 783 0x80000007 0x00B26E
Type-5 AS External Link States
Link
ID ADV Router Age Seq# Checksum Tag
30.1.1.0 3.3.3.3 269 0x8000000D 0x00D691 0
R1#
R1#sh ip ospf database external
OSPF
Router with ID (1.1.1.1) (Process ID 1)
Type-5 AS External Link States
Routing Bit Set
on this LSA
LS age: 313
Options: (No
TOS-capability, DC)
LS Type: AS
External Link
Link State ID:
30.1.1.0 (External Network Number )
Advertising
Router: 3.3.3.3
LS Seq Number:
8000000D
Checksum: 0xD691
Length: 36
Network Mask: /24
Metric
Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward
Address: 0.0.0.0
External
Route Tag: 0
R2:-
2#sh ip ospf neighbor
Neighbor ID
Pri State Dead Time Address Interface
3.3.3.3
1 FULL/DR 00:00:30 23.23.23.3 FastEthernet0/1
1.1.1.1 1
FULL/DR 00:00:38 12.12.12.1 FastEthernet0/0
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M -
mobile, B - BGP
D - EIGRP,
EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2
i - IS-IS,
su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS
inter area, * - candidate default, U - per-user static route
o - ODR, P -
periodic downloaded static route, H - NHRP
+ -
replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is
subnetted, 1 subnets
O 1.1.1.1
[110/2] via 12.12.12.1, 00:14:38, FastEthernet0/0
3.0.0.0/32 is
subnetted, 1 subnets
O 3.3.3.3
[110/2] via 23.23.23.3, 00:14:38, FastEthernet0/1
10.0.0.0/28
is subnetted, 3 subnets
O 10.1.1.0
[110/2] via 12.12.12.1, 00:14:38, FastEthernet0/0
O 10.1.1.16
[110/2] via 12.12.12.1, 00:14:38, FastEthernet0/0
O 10.1.1.32
[110/2] via 12.12.12.1, 00:14:38, FastEthernet0/0
30.0.0.0/24
is subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 23.23.23.3,
00:08:07, FastEthernet0/1
34.0.0.0/24 is subnetted, 1 subnets
O 34.34.34.0
[110/2] via 23.23.23.3, 00:14:38, FastEthernet0/1
45.0.0.0/24
is subnetted, 1 subnets
O IA 45.45.45.0
[110/3] via 23.23.23.3, 00:14:38, FastEthernet0/1
50.0.0.0/24
is subnetted, 1 subnets
O IA 50.1.1.0
[110/4] via 23.23.23.3, 00:14:38, FastEthernet0/1
R2#show ip route 30.1.1.1
Routing
entry for 30.1.1.0/24
Known via
"ospf 1", distance 110, metric 20, type extern 2, forward metric 1
Last update from
23.23.23.3 on FastEthernet0/1, 00:08:15 ago
Routing Descriptor
Blocks:
* 23.23.23.3,
from 3.3.3.3, 00:08:15 ago, via FastEthernet0/1
Route metric
is 20, traffic share count is 1
R2#sh ip ospf database
OSPF
Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum Link count
2.2.2.2
2.2.2.2 1274 0x8000000F 0x00DDA6 1
3.3.3.3
3.3.3.3 1159 0x80000013 0x00E68E 3
4.4.4.4
4.4.4.4 1228 0x8000000E 0x00042C 1
Net
Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum
23.23.23.3
3.3.3.3 1400 0x8000000C 0x009C2A
34.34.34.4
4.4.4.4 1228 0x8000000C 0x003B5D
Summary Net Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum
1.1.1.1
2.2.2.2 1274 0x8000000A 0x002105
10.1.1.0
2.2.2.2 885 0x8000000C 0x0057D3
10.1.1.16 2.2.2.2 890 0x80000001 0x00CC59
10.1.1.32
2.2.2.2 890 0x80000001 0x002CE9
12.12.12.0
2.2.2.2 1274 0x8000000A 0x009373
45.45.45.0
4.4.4.4 1228 0x8000000C 0x00AAEE
50.1.1.0 4.4.4.4 1228 0x8000000C 0x006B80
Router Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum Link count
1.1.1.1
1.1.1.1 1233 0x80000011 0x008FC8 5
2.2.2.2 2.2.2.2 1274 0x8000000F 0x003395 1
Net
Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum
12.12.12.1
1.1.1.1 1740 0x8000000D 0x0034C4
Summary Net Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
2.2.2.2 776 0x80000007 0x00CA56
23.23.23.0
2.2.2.2 1274 0x8000000D 0x00FFE2
34.34.34.0
2.2.2.2 1274 0x8000000D 0x007C44
45.45.45.0
2.2.2.2 1274 0x8000000D 0x00F8A5
50.1.1.0
2.2.2.2 1274 0x8000000D 0x00B937
Summary ASB Link States (Area 1)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
2.2.2.2 1020 0x80000007 0x00B26E
Type-5 AS External Link States
Link
ID ADV Router Age Seq# Checksum Tag
30.1.1.0 3.3.3.3 504 0x8000000D 0x00D691 0
R2#
R3:-
R3#sh ip ospf neighbor
Neighbor ID
Pri State Dead Time Address Interface
4.4.4.4
1 FULL/DR 00:00:35 34.34.34.4 FastEthernet1/0
2.2.2.2
1 FULL/BDR 00:00:38 23.23.23.2 FastEthernet0/1
R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M -
mobile, B - BGP
D - EIGRP,
EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2
i - IS-IS,
su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS
inter area, * - candidate default, U - per-user static route
o - ODR, P -
periodic downloaded static route, H - NHRP
+ -
replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/3] via 23.23.23.2, 03:39:07, FastEthernet0/1
3.0.0.0/32 is
subnetted, 1 subnets
C 3.3.3.3 is
directly connected, Loopback0
10.0.0.0/28
is subnetted, 3 subnets
O IA 10.1.1.0
[110/3] via 23.23.23.2, 00:15:52, FastEthernet0/1
O IA 10.1.1.16
[110/3] via 23.23.23.2, 00:15:57, FastEthernet0/1
O IA 10.1.1.32
[110/3] via 23.23.23.2, 00:15:57, FastEthernet0/1
12.0.0.0/24
is subnetted, 1 subnets
O IA 12.12.12.0
[110/2] via 23.23.23.2, 03:39:07, FastEthernet0/1
23.0.0.0/8 is
variably subnetted, 2 subnets, 2 masks
C
23.23.23.0/24 is directly connected, FastEthernet0/1
L
23.23.23.3/32 is directly connected, FastEthernet0/1
30.0.0.0/8 is
variably subnetted, 7 subnets, 3 masks
O
30.1.1.0/24 is a summary, 00:09:31, Null0
C 30.1.1.0/28 is directly connected,
FastEthernet0/0
L 30.1.1.1/32 is directly connected,
FastEthernet0/0
C 30.1.1.16/28 is directly connected,
FastEthernet2/0
L
30.1.1.17/32 is directly connected, FastEthernet2/0
C 30.1.1.32/28 is directly connected,
FastEthernet3/0
L 30.1.1.33/32
is directly connected, FastEthernet3/0
34.0.0.0/8 is
variably subnetted, 2 subnets, 2 masks
C
34.34.34.0/24 is directly connected, FastEthernet1/0
L
34.34.34.3/32 is directly connected, FastEthernet1/0
45.0.0.0/24
is subnetted, 1 subnets
O IA 45.45.45.0
[110/2] via 34.34.34.4, 03:39:07, FastEthernet1/0
50.0.0.0/24
is subnetted, 1 subnets
O IA 50.1.1.0
[110/3] via 34.34.34.4, 03:39:07, FastEthernet1/0
R3#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M -
mobile, B - BGP
D - EIGRP,
EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2
i - IS-IS,
su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS
inter area, * - candidate default, U - per-user static route
o - ODR, P -
periodic downloaded static route, H - NHRP
+ -
replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/3] via 23.23.23.2, 03:39:11, FastEthernet0/1
10.0.0.0/28
is subnetted, 3 subnets
O IA 10.1.1.0
[110/3] via 23.23.23.2, 00:15:56, FastEthernet0/1
O IA 10.1.1.16
[110/3] via 23.23.23.2, 00:16:01, FastEthernet0/1
O IA 10.1.1.32
[110/3] via 23.23.23.2, 00:16:01, FastEthernet0/1
12.0.0.0/24
is subnetted, 1 subnets
O IA 12.12.12.0
[110/2] via 23.23.23.2, 03:39:11, FastEthernet0/1
30.0.0.0/8 is
variably subnetted, 7 subnets, 3 masks
O 30.1.1.0/24 is a summary, 00:09:35,
Null0
45.0.0.0/24
is subnetted, 1 subnets
O IA 45.45.45.0
[110/2] via 34.34.34.4, 03:39:11, FastEthernet1/0
50.0.0.0/24
is subnetted, 1 subnets
O IA 50.1.1.0
[110/3] via 34.34.34.4, 03:39:11, FastEthernet1/0
R3#sh ip route 30.1.1.0
Routing
entry for 30.1.1.0/28
Known via
"connected", distance 0, metric 0 (connected, via interface)
Redistributing
via ospf 1
Routing
Descriptor Blocks:
* directly
connected, via FastEthernet0/0
Route metric
is 0, traffic share count is 1
R3#sh ip ospf database
OSPF
Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 0)
Link ID ADV
Router Age
Seq# Checksum Link count
2.2.2.2
2.2.2.2 1558 0x8000000F 0x00DDA6 1
3.3.3.3
3.3.3.3 1442 0x80000013 0x00E68E 3
4.4.4.4
4.4.4.4 1511 0x8000000E 0x00042C 1
Net Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum
23.23.23.3
3.3.3.3 1682 0x8000000C 0x009C2A
34.34.34.4
4.4.4.4 1510 0x8000000C 0x003B5D
Summary Net Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum
1.1.1.1
2.2.2.2 1558 0x8000000A 0x002105
10.1.1.0
2.2.2.2 1169 0x8000000C 0x0057D3
10.1.1.16 2.2.2.2 1174 0x80000001 0x00CC59
10.1.1.32
2.2.2.2 1174 0x80000001 0x002CE9
12.12.12.0
2.2.2.2 1558 0x8000000A 0x009373
45.45.45.0
4.4.4.4 1511 0x8000000C 0x00AAEE
50.1.1.0 4.4.4.4 1511 0x8000000C 0x006B80
Type-5 AS External Link States
Link ID ADV
Router Age Seq# Checksum Tag
30.1.1.0 3.3.3.3 787 0x8000000D 0x00D691 0
R3#sh ip ospf database external 30.1.1.0
OSPF
Router with ID (3.3.3.3) (Process ID 1)
Type-5 AS External Link States
LS age: 800
Options: (No
TOS-capability, DC)
LS Type: AS
External Link
Link State ID:
30.1.1.0 (External Network Number )
Advertising
Router: 3.3.3.3
LS Seq Number:
8000000D
Checksum: 0xD691
Length: 36
Network Mask: /24
Metric
Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward
Address: 0.0.0.0
External
Route Tag: 0
R4:-
R4#sh ip ospf neighbor
Neighbor ID
Pri State Dead Time Address Interface
3.3.3.3
1 FULL/BDR 00:00:31 34.34.34.3 FastEthernet1/0
5.5.5.5
1 FULL/BDR 00:00:39 45.45.45.5 FastEthernet0/0
R4#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M -
mobile, B - BGP
D - EIGRP,
EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2
i - IS-IS,
su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS
inter area, * - candidate default, U - per-user static route
o - ODR, P -
periodic downloaded static route, H - NHRP
+ -
replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/4] via 34.34.34.3, 05:41:59, FastEthernet1/0
3.0.0.0/32 is
subnetted, 1 subnets
O 3.3.3.3
[110/2] via 34.34.34.3, 03:51:43, FastEthernet1/0
10.0.0.0/28
is subnetted, 3 subnets
O IA 10.1.1.0
[110/4] via 34.34.34.3, 00:31:00, FastEthernet1/0
O IA 10.1.1.16
[110/4] via 34.34.34.3, 00:31:05, FastEthernet1/0
O IA 10.1.1.32
[110/4] via 34.34.34.3, 00:31:05, FastEthernet1/0
12.0.0.0/24
is subnetted, 1 subnets
O IA 12.12.12.0
[110/3] via 34.34.34.3, 05:41:59, FastEthernet1/0
23.0.0.0/24
is subnetted, 1 subnets
O 23.23.23.0
[110/2] via 34.34.34.3, 05:58:22, FastEthernet1/0
30.0.0.0/24
is subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 34.34.34.3,
00:24:33, FastEthernet1/0
50.0.0.0/24
is subnetted, 1 subnets
O 50.1.1.0
[110/2] via 45.45.45.5, 05:58:22, FastEthernet0/0
R4#sh ip ospf database
OSPF
Router with ID (4.4.4.4) (Process ID 1)
Router Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 244 0x80000010 0x00DBA7 1
3.3.3.3
3.3.3.3 132 0x80000014 0x00E48F 3
4.4.4.4
4.4.4.4 173 0x8000000F 0x00022D 1
Net
Link States (Area 0)
Link ID ADV
Router Age
Seq# Checksum
23.23.23.3
3.3.3.3 379 0x8000000D 0x009A2B
34.34.34.4
4.4.4.4 173 0x8000000D 0x00395E
Summary Net Link States (Area 0)
Link ID ADV
Router Age Seq# Checksum
1.1.1.1
2.2.2.2 244 0x8000000B 0x001F06
10.1.1.0
2.2.2.2 1867 0x8000000C 0x0057D3
10.1.1.16
2.2.2.2 1872 0x80000001 0x00CC59
10.1.1.32
2.2.2.2 1872 0x80000001 0x002CE9
12.12.12.0
2.2.2.2 244 0x8000000B 0x009174
45.45.45.0
4.4.4.4 173 0x8000000D 0x00A8EF
50.1.1.0
4.4.4.4 173 0x8000000D 0x006981
Router Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum Link count
4.4.4.4
4.4.4.4 173 0x8000000E 0x009A53 1
5.5.5.5
5.5.5.5 58 0x8000000E 0x007B1C 2
Net
Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
45.45.45.4
4.4.4.4 173 0x8000000D 0x00105E
Summary Net Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
1.1.1.1 4.4.4.4 426 0x8000000B 0x00F624
3.3.3.3
4.4.4.4 1949 0x80000007 0x008E8A
10.1.1.0
4.4.4.4 1865 0x8000000C 0x002FF1
10.1.1.16
4.4.4.4 1870 0x80000001 0x00A477
10.1.1.32 4.4.4.4 1870 0x80000001 0x000408
12.12.12.0
4.4.4.4 426 0x8000000B 0x006992
23.23.23.0
4.4.4.4 173 0x8000000D 0x00CD0C
34.34.34.0
4.4.4.4 173 0x8000000E 0x003484
Summary
ASB Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
4.4.4.4 1949 0x80000007 0x0076A2
Type-5 AS External Link States
Link ID ADV
Router Age Seq# Checksum Tag
30.1.1.0 3.3.3.3 1484 0x8000000D 0x00D691 0
R4#sh ip ospf database external 30.1.1.0
OSPF
Router with ID (4.4.4.4) (Process ID 1)
Type-5 AS External Link States
Routing Bit Set
on this LSA in topology Base with MTID 0
LS age: 1490
Options: (No
TOS-capability, DC)
LS Type: AS
External Link
Link State ID:
30.1.1.0 (External Network Number )
Advertising
Router: 3.3.3.3
LS Seq Number:
8000000D
Checksum: 0xD691
Length: 36
Network Mask: /24
Metric
Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward
Address: 0.0.0.0
External
Route Tag: 0
R5:-
R5#sh ip ospf neighbor
Neighbor ID
Pri State Dead Time Address Interface
4.4.4.4
1 FULL/DR 00:00:34 45.45.45.4 FastEthernet0/0
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B
- BGP
D - EIGRP,
EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2
i - IS-IS,
su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS
inter area, * - candidate default, U - per-user static route
o - ODR, P -
periodic downloaded static route
Gateway of last resort is not set
34.0.0.0/24 is
subnetted, 1 subnets
O IA 34.34.34.0
[110/11] via 45.45.45.4, 06:45:20, FastEthernet0/0
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/14] via 45.45.45.4, 05:42:40, FastEthernet0/0
50.0.0.0/24 is
subnetted, 1 subnets
C 50.1.1.0 is
directly connected, FastEthernet2/0
3.0.0.0/32 is
subnetted, 1 subnets
O IA 3.3.3.3
[110/12] via 45.45.45.4, 03:52:25, FastEthernet0/0
23.0.0.0/24 is
subnetted, 1 subnets
O IA 23.23.23.0
[110/12] via 45.45.45.4, 06:45:21, FastEthernet0/0
10.0.0.0/28 is
subnetted, 3 subnets
O IA 10.1.1.0
[110/14] via 45.45.45.4, 00:31:42, FastEthernet0/0
O IA 10.1.1.16
[110/14] via 45.45.45.4, 00:31:45, FastEthernet0/0
O IA 10.1.1.32
[110/14] via 45.45.45.4, 00:31:45, FastEthernet0/0
12.0.0.0/24 is
subnetted, 1 subnets
O IA 12.12.12.0
[110/13] via 45.45.45.4, 05:42:42, FastEthernet0/0
45.0.0.0/24 is
subnetted, 1 subnets
C 45.45.45.0
is directly connected, FastEthernet0/0
30.0.0.0/24 is
subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 45.45.45.4,
00:25:21, FastEthernet0/0
R5#sh ip route ospf
34.0.0.0/24 is
subnetted, 1 subnets
O IA 34.34.34.0
[110/11] via 45.45.45.4, 06:45:25, FastEthernet0/0
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/14] via 45.45.45.4, 05:42:46, FastEthernet0/0
3.0.0.0/32 is
subnetted, 1 subnets
O IA 3.3.3.3
[110/12] via 45.45.45.4, 03:52:31, FastEthernet0/0
23.0.0.0/24 is
subnetted, 1 subnets
O IA 23.23.23.0
[110/12] via 45.45.45.4, 06:45:25, FastEthernet0/0
10.0.0.0/28 is
subnetted, 3 subnets
O IA 10.1.1.0
[110/14] via 45.45.45.4, 00:31:47, FastEthernet0/0
O IA 10.1.1.16
[110/14] via 45.45.45.4, 00:31:49, FastEthernet0/0
O IA 10.1.1.32
[110/14] via 45.45.45.4, 00:31:49, FastEthernet0/0
12.0.0.0/24 is
subnetted, 1 subnets
O IA 12.12.12.0
[110/13] via 45.45.45.4, 05:42:46, FastEthernet0/0
30.0.0.0/24 is
subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 45.45.45.4,
00:25:25, FastEthernet0/0
R5#sh ip ospf database
OSPF
Router with ID (5.5.5.5) (Process ID 1)
Router Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum Link count
4.4.4.4
4.4.4.4 221 0x8000000E 0x009A53 1
5.5.5.5
5.5.5.5 104 0x8000000E 0x007B1C 2
Net
Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
45.45.45.4
4.4.4.4 221 0x8000000D 0x00105E
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
1.1.1.1
4.4.4.4 474 0x8000000B 0x00F624
3.3.3.3
4.4.4.4 1998 0x80000007 0x008E8A
10.1.1.0
4.4.4.4 1913 0x8000000C 0x002FF1
10.1.1.16 4.4.4.4 1916 0x80000001 0x00A477
10.1.1.32
4.4.4.4 1916 0x80000001 0x000408
12.12.12.0
4.4.4.4 474 0x8000000B 0x006992
23.23.23.0
4.4.4.4 221 0x8000000D 0x00CD0C
34.34.34.0 4.4.4.4 222 0x8000000E 0x003484
Summary ASB Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
4.4.4.4 1999 0x80000007 0x0076A2
Type-5 AS External Link States
Link ID ADV
Router Age Seq# Checksum Tag
30.1.1.0
3.3.3.3 1534 0x8000000D 0x00D691 0
R5#sh ip ospf database external 30.1.1.0
OSPF
Router with ID (5.5.5.5) (Process ID 1)
Type-5 AS External Link States
Routing Bit Set
on this LSA
LS age: 1545
Options: (No
TOS-capability, DC)
LS Type: AS
External Link
Link State ID:
30.1.1.0 (External Network Number )
Advertising
Router: 3.3.3.3
LS Seq Number:
8000000D
Checksum: 0xD691
Length: 36
Network Mask: /24
Metric
Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward
Address: 0.0.0.0
External
Route Tag: 0
R5:-
R5#sh ip ospf neighbor
Neighbor ID
Pri State Dead Time Address Interface
4.4.4.4
1 FULL/DR 00:00:34 45.45.45.4 FastEthernet0/0
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B
- BGP
D - EIGRP,
EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2
i - IS-IS,
su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS
inter area, * - candidate default, U - per-user static route
o - ODR, P -
periodic downloaded static route
Gateway of last resort is not set
34.0.0.0/24 is
subnetted, 1 subnets
O IA 34.34.34.0
[110/11] via 45.45.45.4, 06:45:20, FastEthernet0/0
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/14] via 45.45.45.4, 05:42:40, FastEthernet0/0
50.0.0.0/24 is
subnetted, 1 subnets
C 50.1.1.0 is
directly connected, FastEthernet2/0
3.0.0.0/32 is
subnetted, 1 subnets
O IA 3.3.3.3
[110/12] via 45.45.45.4, 03:52:25, FastEthernet0/0
23.0.0.0/24 is
subnetted, 1 subnets
O IA 23.23.23.0
[110/12] via 45.45.45.4, 06:45:21, FastEthernet0/0
10.0.0.0/28 is
subnetted, 3 subnets
O IA 10.1.1.0
[110/14] via 45.45.45.4, 00:31:42, FastEthernet0/0
O IA 10.1.1.16
[110/14] via 45.45.45.4, 00:31:45, FastEthernet0/0
O IA 10.1.1.32
[110/14] via 45.45.45.4, 00:31:45, FastEthernet0/0
12.0.0.0/24 is
subnetted, 1 subnets
O IA 12.12.12.0
[110/13] via 45.45.45.4, 05:42:42, FastEthernet0/0
45.0.0.0/24 is
subnetted, 1 subnets
C 45.45.45.0
is directly connected, FastEthernet0/0
30.0.0.0/24 is
subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 45.45.45.4,
00:25:21, FastEthernet0/0
R5#sh ip route ospf
34.0.0.0/24 is
subnetted, 1 subnets
O IA 34.34.34.0
[110/11] via 45.45.45.4, 06:45:25, FastEthernet0/0
1.0.0.0/32 is
subnetted, 1 subnets
O IA 1.1.1.1
[110/14] via 45.45.45.4, 05:42:46, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3
[110/12] via 45.45.45.4, 03:52:31, FastEthernet0/0
23.0.0.0/24 is
subnetted, 1 subnets
O IA 23.23.23.0
[110/12] via 45.45.45.4, 06:45:25, FastEthernet0/0
10.0.0.0/28 is
subnetted, 3 subnets
O IA 10.1.1.0
[110/14] via 45.45.45.4, 00:31:47, FastEthernet0/0
O IA 10.1.1.16
[110/14] via 45.45.45.4, 00:31:49, FastEthernet0/0
O IA 10.1.1.32
[110/14] via 45.45.45.4, 00:31:49, FastEthernet0/0
12.0.0.0/24 is
subnetted, 1 subnets
O IA 12.12.12.0 [110/13] via 45.45.45.4, 05:42:46,
FastEthernet0/0
30.0.0.0/24 is
subnetted, 1 subnets
O
E2 30.1.1.0 [110/20] via 45.45.45.4,
00:25:25, FastEthernet0/0
R5#sh ip ospf database
OSPF
Router with ID (5.5.5.5) (Process ID 1)
Router Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum Link count
4.4.4.4
4.4.4.4 221 0x8000000E 0x009A53 1
5.5.5.5
5.5.5.5 104 0x8000000E 0x007B1C 2
Net
Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
45.45.45.4
4.4.4.4 221 0x8000000D 0x00105E
Summary Net Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
1.1.1.1
4.4.4.4 474 0x8000000B 0x00F624
3.3.3.3
4.4.4.4 1998 0x80000007 0x008E8A
10.1.1.0
4.4.4.4 1913 0x8000000C 0x002FF1
10.1.1.16
4.4.4.4 1916 0x80000001 0x00A477
10.1.1.32
4.4.4.4 1916 0x80000001 0x000408
12.12.12.0
4.4.4.4 474 0x8000000B 0x006992
23.23.23.0
4.4.4.4 221 0x8000000D 0x00CD0C
34.34.34.0
4.4.4.4 222 0x8000000E 0x003484
Summary ASB Link States (Area 2)
Link ID ADV
Router Age Seq# Checksum
3.3.3.3
4.4.4.4 1999 0x80000007 0x0076A2
Type-5 AS External Link States
Link ID ADV
Router Age Seq# Checksum Tag
30.1.1.0 3.3.3.3 1534 0x8000000D 0x00D691 0
No comments:
Post a Comment