Thursday 13 April 2017

Summarization configuration example- Eigrp



R1:-

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

interface FastEthernet2/0
description "connected to R2"
 ip address 12.12.12.1 255.255.255.0
no shut

router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0
 eigrp router-id 1.1.1.1
no auto-summ


R2:-

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface FastEthernet0/0
description "connected to R3"
 ip address 23.23.23.2 255.255.255.0
no shut

interface FastEthernet1/0
description "connected to R5”
 ip address 25.25.25.2 255.255.255.0
no shut

interface FastEthernet2/0
description "connected to R5"
 ip address 12.12.12.2 255.255.255.0
 ip summary-address eigrp 1 10.1.1.0 255.255.255.0
no shut

interface FastEthernet3/0
description "connected to LAN"
 ip address 10.1.1.1 255.255.255.240
no shut

interface FastEthernet1/1
description "connected to R4”
 ip address 24.24.24.2 255.255.255.0
no shut

router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 10.1.1.1 0.0.0.0
 network 12.12.12.2 0.0.0.0
 network 23.23.23.2 0.0.0.0
 network 25.25.25.2 0.0.0.0
network 24.24.24.2 0.0.0.0
 eigrp router-id 2.2.2.2


R3:-


interface Loopback0
 ip address 3.3.3.3 255.255.255.255

interface FastEthernet0/0
 description "connected to R2"
 ip address 23.23.23.3 255.255.255.0
no shut

interface FastEthernet3/0
description "connected to LAN"
 ip address 10.1.1.17 255.255.255.240
no shut

router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 10.1.1.17 0.0.0.0
 network 23.23.23.3 0.0.0.0
 eigrp router-id 3.3.3.3

R4:-

interface Loopback0
 ip address 4.4.4.4 255.255.255.0

interface FastEthernet1/1
description "connected to R2"
 ip address 24.24.24.4 255.255.255.0
no shut

interface FastEthernet3/0
description "connected to LAN"

 ip address 10.1.1.49 255.255.255.240
no shut

router eigrp 1
 network 4.4.4.4 0.0.0.0
 network 10.1.1.49 0.0.0.0
 network 24.24.24.4 0.0.0.0



R5:-

interface Loopback0
 ip address 5.5.5.5 255.255.255.255

interface FastEthernet1/0
description "connected to R2"
 ip address 25.25.25.5 255.255.255.0
no shut

interface FastEthernet3/0
description "connected to LAN"
 ip address 10.1.1.33 255.255.255.240
no shut

router eigrp 1
 network 5.5.5.5 0.0.0.0
 network 10.1.1.33 0.0.0.0
 network 25.25.25.5 0.0.0.0
 eigrp router-id 5.5.5.5


Verification:-

R1:-

R1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   12.12.12.2              Fa2/0             11 01:26:51  246  1476  0  27


R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/156160] via 12.12.12.2, 01:50:04, FastEthernet2/0
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/158720] via 12.12.12.2, 01:49:17, FastEthernet2/0
      4.0.0.0/24 is subnetted, 1 subnets
D        4.4.4.0 [90/158720] via 12.12.12.2, 00:04:01, FastEthernet2/0
      10.0.0.0/24 is subnetted, 1 subnets
D        10.1.1.0 [90/30720] via 12.12.12.2, 01:43:22, FastEthernet2/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, FastEthernet2/0
L        12.12.12.1/32 is directly connected, FastEthernet2/0
      23.0.0.0/24 is subnetted, 1 subnets
D        23.23.23.0 [90/30720] via 12.12.12.2, 01:49:17, FastEthernet2/0
      24.0.0.0/24 is subnetted, 1 subnets
D        24.24.24.0 [90/30720] via 12.12.12.2, 00:04:03, FastEthernet2/0
      25.0.0.0/24 is subnetted, 1 subnets
D        25.25.25.0 [90/30720] via 12.12.12.2, 01:48:25, FastEthernet2/0


R2:-


R2#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(2)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   23.23.23.3              Fa0/0             14 01:53:38 1402  5000  0  4
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
3   24.24.24.4              Fa1/1             12 00:04:18   24   200  0  5
2   25.25.25.5              Fa1/0             12 01:48:39   35   210  0  9
1   23.23.23.3              Fa0/0             13 01:49:32   45   270  0  9
0   12.12.12.1              Fa2/0             11 01:50:21   48   432  0  15
R2#sh ip rou
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/156160] via 12.12.12.1, 01:50:21, FastEthernet2/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/156160] via 23.23.23.3, 01:49:34, FastEthernet0/0
      4.0.0.0/24 is subnetted, 1 subnets
D        4.4.4.0 [90/156160] via 24.24.24.4, 00:04:18, FastEthernet1/1
      5.0.0.0/32 is subnetted, 1 subnets
B        5.5.5.5 [20/0] via 25.25.25.5, 01:52:21
      10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D        10.1.1.0/24 is a summary, 00:04:18, Null0
C        10.1.1.0/28 is directly connected, FastEthernet3/0
L        10.1.1.1/32 is directly connected, FastEthernet3/0
D        10.1.1.16/28 [90/30720] via 23.23.23.3, 01:45:11, FastEthernet0/0
D        10.1.1.32/28 [90/30720] via 25.25.25.5, 01:44:33, FastEthernet1/0
D        10.1.1.48/28 [90/30720] via 24.24.24.4, 00:02:21, FastEthernet1/1
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, FastEthernet2/0
L        12.12.12.2/32 is directly connected, FastEthernet2/0
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.23.23.0/24 is directly connected, FastEthernet0/0
L        23.23.23.2/32 is directly connected, FastEthernet0/0
      24.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        24.24.24.0/24 is directly connected, FastEthernet1/1
L        24.24.24.2/32 is directly connected, FastEthernet1/1
      25.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        25.25.25.0/24 is directly connected, FastEthernet1/0
L        25.25.25.2/32 is directly connected, FastEthernet1/0
      34.0.0.0/24 is subnetted, 1 subnets
D        34.34.34.0 [90/30720] via 23.23.23.3, 01:53:38, FastEthernet0/0
R2#

R3:-

R3#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   23.23.23.2              Fa0/0             13 01:50:25   68   408  0  41
R3#sh ip rou
R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/158720] via 23.23.23.2, 00:00:21, FastEthernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/156160] via 23.23.23.2, 00:00:21, FastEthernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
      4.0.0.0/24 is subnetted, 1 subnets
D        4.4.4.0 [90/158720] via 23.23.23.2, 00:00:21, FastEthernet0/0
      5.0.0.0/32 is subnetted, 1 subnets
B        5.5.5.5 [200/0] via 23.23.23.2, 00:00:21
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.1.0/28 [90/30720] via 23.23.23.2, 00:00:21, FastEthernet0/0
C        10.1.1.16/28 is directly connected, FastEthernet3/0
L        10.1.1.17/32 is directly connected, FastEthernet3/0
D        10.1.1.32/28 [90/33280] via 23.23.23.2, 00:00:21, FastEthernet0/0
D        10.1.1.48/28 [90/33280] via 23.23.23.2, 00:00:21, FastEthernet0/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, FastEthernet2/0
L        12.12.12.2/32 is directly connected, FastEthernet2/0
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.23.23.0/24 is directly connected, FastEthernet0/0
L        23.23.23.3/32 is directly connected, FastEthernet0/0
      24.0.0.0/24 is subnetted, 1 subnets
D        24.24.24.0 [90/30720] via 23.23.23.2, 00:00:21, FastEthernet0/0
      25.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        25.25.25.0/24 is directly connected, FastEthernet1/0
L        25.25.25.2/32 is directly connected, FastEthernet1/0
      34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.34.34.0/24 is directly connected, FastEthernet0/1
L        34.34.34.3/32 is directly connected, FastEthernet0/1

R4:-

R4#     sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   24.24.24.2              Fa1/1             12 00:06:04   43   258  0  38

R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/158720] via 24.24.24.2, 00:06:03, FastEthernet1/1
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/156160] via 24.24.24.2, 00:06:03, FastEthernet1/1
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/158720] via 24.24.24.2, 00:06:03, FastEthernet1/1
      4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        4.4.4.0/24 is directly connected, Loopback0
L        4.4.4.4/32 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.1.0/28 [90/30720] via 24.24.24.2, 00:06:03, FastEthernet1/1
D        10.1.1.16/28 [90/33280] via 24.24.24.2, 00:06:03, FastEthernet1/1
D        10.1.1.32/28 [90/33280] via 24.24.24.2, 00:06:03, FastEthernet1/1
C        10.1.1.48/28 is directly connected, FastEthernet3/0
L        10.1.1.49/32 is directly connected, FastEthernet3/0
      12.0.0.0/24 is subnetted, 1 subnets
D        12.12.12.0 [90/30720] via 24.24.24.2, 00:06:03, FastEthernet1/1
      23.0.0.0/24 is subnetted, 1 subnets
D        23.23.23.0 [90/30720] via 24.24.24.2, 00:06:03, FastEthernet1/1
      24.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        24.24.24.0/24 is directly connected, FastEthernet1/1
L        24.24.24.4/32 is directly connected, FastEthernet1/1
      25.0.0.0/24 is subnetted, 1 subnets
D        25.25.25.0 [90/30720] via 24.24.24.2, 00:06:03, FastEthernet1/1

R5:-

R5#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   25.25.25.2              Fa1/0             13 01:49:52   54   324  0  40
R5#sh ip rou
R5#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/158720] via 25.25.25.2, 01:49:54, FastEthernet1/0
      2.0.0.0/32 is subnetted, 1 subnets
B        2.2.2.2 [20/0] via 25.25.25.2, 01:53:34
      3.0.0.0/32 is subnetted, 1 subnets
B        3.3.3.3 [20/0] via 25.25.25.2, 01:53:34
      4.0.0.0/24 is subnetted, 1 subnets
D        4.4.4.0 [90/158720] via 25.25.25.2, 00:05:31, FastEthernet1/0
      5.0.0.0/32 is subnetted, 1 subnets
C        5.5.5.5 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.1.0/28 [90/30720] via 25.25.25.2, 01:49:00, FastEthernet1/0
D        10.1.1.16/28 [90/33280] via 25.25.25.2, 01:46:24, FastEthernet1/0
C        10.1.1.32/28 is directly connected, FastEthernet3/0
L        10.1.1.33/32 is directly connected, FastEthernet3/0
D        10.1.1.48/28 [90/33280] via 25.25.25.2, 00:03:34, FastEthernet1/0
      12.0.0.0/24 is subnetted, 1 subnets
D        12.12.12.0 [90/30720] via 25.25.25.2, 01:49:54, FastEthernet1/0
      23.0.0.0/24 is subnetted, 1 subnets
D        23.23.23.0 [90/30720] via 25.25.25.2, 01:49:54, FastEthernet1/0
      24.0.0.0/24 is subnetted, 1 subnets
D        24.24.24.0 [90/30720] via 25.25.25.2, 00:05:33, FastEthernet1/0
      25.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        25.25.25.0/24 is directly connected, FastEthernet1/0
L        25.25.25.5/32 is directly connected, FastEthernet1/0

R5#

No comments:

Post a Comment