Friday 28 April 2017

Inter-Area Route Summarization - OSPF

 

R1:-

interface Loopback0
 ip address 1.1.1.1 255.255.255.255



interface FastEthernet0/0
 description *** Connected to R2***
 ip address 12.12.12.1 255.255.255.0
no shut



interface FastEthernet1/0
description *** Connected to LAN1***
 ip address 10.1.1.17 255.255.255.240
no shut



interface FastEthernet2/0
description *** Connected to LAN2***
 ip address 10.1.1.1 255.255.255.240
no shut



interface FastEthernet3/0
description *** Connected to LAN3***
 ip address 10.1.1.33 255.255.255.240
no shut



router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 1
 network 10.1.1.1 0.0.0.0 area 1
 network 10.1.1.17 0.0.0.0 area 1
 network 10.1.1.33 0.0.0.0 area 1
 network 12.12.12.1 0.0.0.0 area 1


R2:-

interface FastEthernet0/0
description *** Connected to R1***
 ip address 12.12.12.2 255.255.255.0
no shut



interface FastEthernet0/1
description *** Connected to R3***
 ip address 23.23.23.2 255.255.255.0
no shut



router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 1 range 10.1.1.0 255.255.255.0        \\ Only ABR of Area can do the summarization for area1 Routes
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 1
 network 23.23.23.2 0.0.0.0 area 0



R3:-
interface FastEthernet0/1
description *** Connected to R2***
 ip address 23.23.23.3 255.255.255.0
no shut



interface FastEthernet1/0
description *** Connected to R4***
 ip address 34.34.34.3 255.255.255.0
no shut



router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0



R4:-

interface FastEthernet0/0
description *** Connected to R5***
 ip address 45.45.45.4 255.255.255.0
no shut



interface FastEthernet1/0
description *** Connected to R3***
 ip address 34.34.34.4 255.255.255.0
no shut



router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
 network 34.34.34.4 0.0.0.0 area 0
 network 45.45.45.4 0.0.0.0 area 2



R5:-

interface FastEthernet0/0
 description *** Connected to R4***
 ip address 45.45.45.5 255.255.255.0
no shut



interface FastEthernet2/0
description *** Connected to LAN1***
 ip address 50.1.1.1 255.255.255.0
no shut



router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 2
 network 45.45.45.5 0.0.0.0 area 2
 network 50.1.1.1 0.0.0.0 area 2


PC1:-

PC1> sh ip
NAME        : PC1[1]
IP/MASK     : 10.1.1.10/24
GATEWAY     : 10.1.1.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10005
RHOST:PORT  : 127.0.0.1:10004
MTU:        : 1500

PC2:-
PC2> show ip

NAME        : PC2[1]
IP/MASK     : 50.1.1.10/24
GATEWAY     : 50.1.1.1
DNS         :
MAC         : 00:50:79:66:68:01
LPORT       : 10011
RHOST:PORT  : 127.0.0.1:10010
MTU:        : 1500


Verification:-


R1:-


R1# show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:36    12.12.12.2      FastEthernet0/0

ESW1#show ip ospf database
            OSPF Router with ID (1.1.1.1) (Process ID 1)
                Router Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         30          0x8000000A 0x009DC1 5
2.2.2.2         2.2.2.2         227         0x80000008 0x00418E 1

                Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
12.12.12.1      1.1.1.1         527         0x80000006 0x0042BD

                Summary Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
23.23.23.0      2.2.2.2         227         0x80000006 0x000EDB
34.34.34.0      2.2.2.2         227         0x80000006 0x008A3D
45.45.45.0      2.2.2.2         227         0x80000006 0x00079E
50.1.1.0        2.2.2.2         2024        0x80000005 0x00C92F




R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set
     34.0.0.0/24 is subnetted, 1 subnets
O IA    34.34.34.0 [110/12] via 12.12.12.2, 01:11:54, FastEthernet0/0
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     50.0.0.0/24 is subnetted, 1 subnets
O IA    50.1.1.0 [110/14] via 12.12.12.2, 01:11:54, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.23.23.0 [110/11] via 12.12.12.2, 01:11:54, FastEthernet0/0
     10.0.0.0/28 is subnetted, 3 subnets
C       10.1.1.0 is directly connected, FastEthernet2/0
C       10.1.1.16 is directly connected, FastEthernet1/0
C       10.1.1.32 is directly connected, FastEthernet3/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
O IA    45.45.45.0 [110/13] via 12.12.12.2, 01:11:57, FastEthernet0/0




R2:-


R2#sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:35    23.23.23.3      FastEthernet0/1
1.1.1.1           1   FULL/DR         00:00:39    12.12.12.1      FastEthernet0/0


R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set
      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 12.12.12.1, 01:12:52, FastEthernet0/0
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O        10.1.1.0/24 is a summary, 01:12:52, Null0
O        10.1.1.0/28 [110/2] via 12.12.12.1, 01:12:52, FastEthernet0/0
O        10.1.1.16/28 [110/2] via 12.12.12.1, 01:12:52, FastEthernet0/0
O        10.1.1.32/28 [110/2] via 12.12.12.1, 01:12:52, FastEthernet0/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, FastEthernet0/0
L        12.12.12.2/32 is directly connected, FastEthernet0/0
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.23.23.0/24 is directly connected, FastEthernet0/1
L        23.23.23.2/32 is directly connected, FastEthernet0/1
      34.0.0.0/24 is subnetted, 1 subnets
O        34.34.34.0 [110/2] via 23.23.23.3, 01:13:02, FastEthernet0/1
      45.0.0.0/24 is subnetted, 1 subnets
O IA     45.45.45.0 [110/3] via 23.23.23.3, 01:13:02, FastEthernet0/1
      50.0.0.0/24 is subnetted, 1 subnets
O IA     50.1.1.0 [110/4] via 23.23.23.3, 01:13:02, FastEthernet0/1



R2#sh ip ospf database
            OSPF Router with ID (2.2.2.2) (Process ID 1)
                Router Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         296         0x80000008 0x00EB9F 1
3.3.3.3         3.3.3.3         322         0x80000008 0x003669 2
4.4.4.4         4.4.4.4         182         0x80000007 0x001225 1

                Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
23.23.23.3      3.3.3.3         322         0x80000005 0x00AA23
34.34.34.4      4.4.4.4         182         0x80000005 0x004956

                Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
1.1.1.1         2.2.2.2         296         0x80000003 0x002FFD
10.1.1.0        2.2.2.2         296         0x80000003 0x00C361
12.12.12.0      2.2.2.2         296         0x80000003 0x00A16C
45.45.45.0      4.4.4.4         182         0x80000005 0x00B8E7
50.1.1.0        4.4.4.4         182         0x80000005 0x007979

                Router Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         102         0x8000000A 0x009DC1 5
2.2.2.2         2.2.2.2         296         0x80000008 0x00418E 1

                Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
12.12.12.1      1.1.1.1         599         0x80000006 0x0042BD

                Summary Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
23.23.23.0      2.2.2.2         296         0x80000006 0x000EDB
34.34.34.0      2.2.2.2         296         0x80000006 0x008A3D
45.45.45.0      2.2.2.2         296         0x80000006 0x00079E
50.1.1.0        2.2.2.2         41          0x80000006 0x00C730

R2#sh ip route 10.1.1.1
Routing entry for 10.1.1.0/28
  Known via "ospf 1", distance 110, metric 2, type intra area
  Last update from 12.12.12.1 on FastEthernet0/0, 01:21:58 ago
  Routing Descriptor Blocks:
  * 12.12.12.1, from 1.1.1.1, 01:21:58 ago, via FastEthernet0/0
      Route metric is 2, traffic share count is 1



R3:-


R3# sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           1   FULL/DR         00:00:38    34.34.34.4      FastEthernet1/0
2.2.2.2           1   FULL/BDR        00:00:33    23.23.23.2      FastEthernet0/1

R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set
      1.0.0.0/32 is subnetted, 1 subnets
O IA     1.1.1.1 [110/3] via 23.23.23.2, 01:20:26, FastEthernet0/1
      10.0.0.0/24 is subnetted, 1 subnets
O IA     10.1.1.0 [110/3] via 23.23.23.2, 01:20:26, FastEthernet0/1
      12.0.0.0/24 is subnetted, 1 subnets
O IA     12.12.12.0 [110/2] via 23.23.23.2, 01:20:26, FastEthernet0/1
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.23.23.0/24 is directly connected, FastEthernet0/1
L        23.23.23.3/32 is directly connected, FastEthernet0/1
      34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.34.34.0/24 is directly connected, FastEthernet1/0
L        34.34.34.3/32 is directly connected, FastEthernet1/0
      45.0.0.0/24 is subnetted, 1 subnets
O IA     45.45.45.0 [110/2] via 34.34.34.4, 02:24:45, FastEthernet1/0
      50.0.0.0/24 is subnetted, 1 subnets
O IA     50.1.1.0 [110/3] via 34.34.34.4, 02:23:04, FastEthernet1/0



R3#sh ip ospf database
            OSPF Router with ID (3.3.3.3) (Process ID 1)
                Router Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         750         0x80000008 0x00EB9F 1
3.3.3.3         3.3.3.3         774         0x80000008 0x003669 2
4.4.4.4         4.4.4.4         634         0x80000007 0x001225 1

                Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
23.23.23.3      3.3.3.3         774         0x80000005 0x00AA23
34.34.34.4      4.4.4.4         634         0x80000005 0x004956

                Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
1.1.1.1         2.2.2.2         750         0x80000003 0x002FFD
10.1.1.0        2.2.2.2         750         0x80000003 0x00C361
12.12.12.0      2.2.2.2         750         0x80000003 0x00A16C
45.45.45.0      4.4.4.4         634         0x80000005 0x00B8E7
50.1.1.0        4.4.4.4         634         0x80000005 0x007979
R3#

R3#sh ip route 10.1.1.1
Routing entry for 10.1.1.0/24
  Known via "ospf 1", distance 110, metric 3, type inter area
  Last update from 23.23.23.2 on FastEthernet0/1, 01:22:08 ago
  Routing Descriptor Blocks:
  * 23.23.23.2, from 2.2.2.2, 01:22:08 ago, via FastEthernet0/1
      Route metric is 3, traffic share count is 1



R4:-

R4#sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:34    34.34.34.3      FastEthernet1/0
5.5.5.5           1   FULL/BDR        00:00:38    45.45.45.5      FastEthernet0/0



R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set
      1.0.0.0/32 is subnetted, 1 subnets
O IA     1.1.1.1 [110/4] via 34.34.34.3, 01:21:09, FastEthernet1/0
      10.0.0.0/24 is subnetted, 1 subnets
O IA     10.1.1.0 [110/4] via 34.34.34.3, 01:21:09, FastEthernet1/0
      12.0.0.0/24 is subnetted, 1 subnets
O IA     12.12.12.0 [110/3] via 34.34.34.3, 01:21:09, FastEthernet1/0
      23.0.0.0/24 is subnetted, 1 subnets
O        23.23.23.0 [110/2] via 34.34.34.3, 01:37:32, FastEthernet1/0
      34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.34.34.0/24 is directly connected, FastEthernet1/0
L        34.34.34.4/32 is directly connected, FastEthernet1/0
      45.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        45.45.45.0/24 is directly connected, FastEthernet0/0
L        45.45.45.4/32 is directly connected, FastEthernet0/0
      50.0.0.0/24 is subnetted, 1 subnets
O        50.1.1.0 [110/2] via 45.45.45.5, 01:37:32, FastEthernet0/0



R4#sh ip ospf database
            OSPF Router with ID (4.4.4.4) (Process ID 1)
                Router Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         796         0x80000008 0x00EB9F 1
3.3.3.3         3.3.3.3         819         0x80000008 0x003669 2
4.4.4.4         4.4.4.4         677         0x80000007 0x001225 1

                Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
23.23.23.3      3.3.3.3         819         0x80000005 0x00AA23
34.34.34.4      4.4.4.4         677         0x80000005 0x004956

                Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
1.1.1.1         2.2.2.2         796         0x80000003 0x002FFD
10.1.1.0        2.2.2.2         796         0x80000003 0x00C361
12.12.12.0      2.2.2.2         796         0x80000003 0x00A16C
45.45.45.0      4.4.4.4         677         0x80000005 0x00B8E7
50.1.1.0        4.4.4.4         677         0x80000005 0x007979

                Router Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum Link count
4.4.4.4         4.4.4.4         677         0x80000006 0x00AA4B 1
5.5.5.5         5.5.5.5         565         0x80000006 0x008B14 2

                Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
45.45.45.4      4.4.4.4         677         0x80000005 0x002056

                Summary Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
1.1.1.1         4.4.4.4         922         0x80000003 0x00071C
10.1.1.0        4.4.4.4         922         0x80000003 0x009B7F
12.12.12.0      4.4.4.4         922         0x80000003 0x00798A
23.23.23.0      4.4.4.4         677         0x80000005 0x00DD04
34.34.34.0      4.4.4.4         677         0x80000006 0x00447C



R5:-


R5#sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           1   FULL/DR         00:00:35    45.45.45.4      FastEthernet0/0

ESW2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set
     34.0.0.0/24 is subnetted, 1 subnets
O IA    34.34.34.0 [110/11] via 45.45.45.4, 02:25:30, FastEthernet0/0
     1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/14] via 45.45.45.4, 01:22:51, FastEthernet0/0
     50.0.0.0/24 is subnetted, 1 subnets
C       50.1.1.0 is directly connected, FastEthernet2/0
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.23.23.0 [110/12] via 45.45.45.4, 02:25:30, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
O IA    10.1.1.0 [110/14] via 45.45.45.4, 01:22:53, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
O IA    12.12.12.0 [110/13] via 45.45.45.4, 01:22:53, FastEthernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
C       45.45.45.0 is directly connected, FastEthernet0/0



R5#   sh ip ospf database
            OSPF Router with ID (5.5.5.5) (Process ID 1)
                Router Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum Link count
4.4.4.4         4.4.4.4         788         0x80000006 0x00AA4B 1
5.5.5.5         5.5.5.5         673         0x80000006 0x008B14 2

                Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
45.45.45.4      4.4.4.4         788         0x80000005 0x002056

                Summary Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
1.1.1.1         4.4.4.4         1032        0x80000003 0x00071C
10.1.1.0        4.4.4.4         1032        0x80000003 0x009B7F
12.12.12.0      4.4.4.4         1032        0x80000003 0x00798A
23.23.23.0      4.4.4.4         788         0x80000005 0x00DD04
34.34.34.0      4.4.4.4         788         0x80000006 0x00447C


PC1:-
PC1> ping 50.1.1.10
84 bytes from 50.1.1.10 icmp_seq=1 ttl=59 time=171.600 ms
84 bytes from 50.1.1.10 icmp_seq=2 ttl=59 time=156.000 ms
84 bytes from 50.1.1.10 icmp_seq=3 ttl=59 time=141.400 ms
84 bytes from 50.1.1.10 icmp_seq=4 ttl=59 time=140.400 ms
84 bytes from 50.1.1.10 icmp_seq=5 ttl=59 time=93.600 ms



PC2:-
PC2> ping 10.1.1.10
84 bytes from 10.1.1.10 icmp_seq=1 ttl=59 time=140.400 ms
84 bytes from 10.1.1.10 icmp_seq=2 ttl=59 time=140.400 ms
84 bytes from 10.1.1.10 icmp_seq=3 ttl=59 time=156.000 ms
84 bytes from 10.1.1.10 icmp_seq=4 ttl=59 time=156.000 ms
84 bytes from 10.1.1.10 icmp_seq=5 ttl=59 time=156.000 ms

No comments:

Post a Comment